aboutsummaryrefslogtreecommitdiff
path: root/net/appkonference
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-22 23:05:38 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-08-22 23:05:38 +0000
commit69490264a5e44cf85ad5519e5c83324b813710ea (patch)
tree3c2800fcc06c518a30bd425ba1f5c1d4ae2b5bd5 /net/appkonference
parent476d4f7f12b1bda3a7b5c933aa786117f58aa33f (diff)
downloadports-69490264a5e44cf85ad5519e5c83324b813710ea.tar.gz
ports-69490264a5e44cf85ad5519e5c83324b813710ea.zip
net/appkonference: fix build on powerpc64
MFH: 2020Q3 (fix build blanket)
Notes
Notes: svn path=/head/; revision=545790
Diffstat (limited to 'net/appkonference')
-rw-r--r--net/appkonference/Makefile2
-rw-r--r--net/appkonference/files/patch-konference_libwebrtc_typedefs.h23
2 files changed, 24 insertions, 1 deletions
diff --git a/net/appkonference/Makefile b/net/appkonference/Makefile
index 9f55ea0964d4..9c2bfb2a1e48 100644
--- a/net/appkonference/Makefile
+++ b/net/appkonference/Makefile
@@ -13,7 +13,7 @@ COMMENT= High-performance Asterisk voice/video conferencing plugin
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc powerpc64
ONLY_FOR_ARCHS_REASON= not yet ported to this architecture
BUILD_DEPENDS= asterisk:net/asterisk13
diff --git a/net/appkonference/files/patch-konference_libwebrtc_typedefs.h b/net/appkonference/files/patch-konference_libwebrtc_typedefs.h
new file mode 100644
index 000000000000..bb127c593b25
--- /dev/null
+++ b/net/appkonference/files/patch-konference_libwebrtc_typedefs.h
@@ -0,0 +1,23 @@
+--- libwebrtc/typedefs.h.orig 2019-08-04 15:52:12 UTC
++++ libwebrtc/typedefs.h
+@@ -48,7 +48,19 @@
+ #define WEBRTC_ARCH_32_BITS
+ #define WEBRTC_ARCH_LITTLE_ENDIAN
+ #else
+-#error Please add support for your architecture in typedefs.h
++/* instead of failing, use typical unix defines... */
++#if __BYTE_ORDER__ == __ORDER_LITTLE_ENDIAN__
++#define WEBRTC_ARCH_LITTLE_ENDIAN
++#elif __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
++#define WEBRTC_ARCH_BIG_ENDIAN
++#else
++#error __BYTE_ORDER__ is not defined
++#endif
++#if defined(__LP64__)
++#define WEBRTC_ARCH_64_BITS
++#else
++#define WEBRTC_ARCH_32_BITS
++#endif
+ #endif
+
+ #if !(defined(WEBRTC_ARCH_LITTLE_ENDIAN) ^ defined(WEBRTC_ARCH_BIG_ENDIAN))