aboutsummaryrefslogtreecommitdiff
path: root/net/arping
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2000-10-16 14:27:46 +0000
committerJames E. Housley <jeh@FreeBSD.org>2000-10-16 14:27:46 +0000
commitabded24d7983594f851ecb083933b5d54411ca92 (patch)
tree2f6e229c85c6aaf977dc988fe58d28277793943a /net/arping
parent7df4b70ce430cc6dc2b4a46a8048725d06f94429 (diff)
downloadports-abded24d7983594f851ecb083933b5d54411ca92.tar.gz
ports-abded24d7983594f851ecb083933b5d54411ca92.zip
Add net/arping v0.95. ARP level "ping" utility
PR: 21670, 21778 Submitted by: Roman Shterenzon <roman@xpert.com>
Notes
Notes: svn path=/head/; revision=33899
Diffstat (limited to 'net/arping')
-rw-r--r--net/arping/Makefile24
-rw-r--r--net/arping/distinfo1
-rw-r--r--net/arping/pkg-comment1
-rw-r--r--net/arping/pkg-descr9
-rw-r--r--net/arping/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
new file mode 100644
index 000000000000..ff2fb9feac93
--- /dev/null
+++ b/net/arping/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: arping
+# Date Created: 1 Oct 2000
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arping
+PORTVERSION= 0.95
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.nss.nu/pub/synscan/
+
+MAINTAINER= roman@xpert.com
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+ALL_TARGET= freebsd
+MAN8= arping.8
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/arping ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/arping.8 ${PREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/net/arping/distinfo b/net/arping/distinfo
new file mode 100644
index 000000000000..8df82439e07f
--- /dev/null
+++ b/net/arping/distinfo
@@ -0,0 +1 @@
+MD5 (arping-0.95.tar.gz) = a9647360fc8b5b4caeec38bd3256228c
diff --git a/net/arping/pkg-comment b/net/arping/pkg-comment
new file mode 100644
index 000000000000..9b227d07dbc5
--- /dev/null
+++ b/net/arping/pkg-comment
@@ -0,0 +1 @@
+ARP level "ping" utility
diff --git a/net/arping/pkg-descr b/net/arping/pkg-descr
new file mode 100644
index 000000000000..7fed1058a452
--- /dev/null
+++ b/net/arping/pkg-descr
@@ -0,0 +1,9 @@
+Arping is a util to find out it a specific IP address on the LAN is 'taken'
+and what MAC address owns it. Sure, you *could* just use 'ping' to find out if
+it's taken and even if the computer blocks ping (and everything else) you still
+get an entry in your arp cache. But what if you aren't on a routable net? Then
+you're screwed. Or you use arping.
+
+WWW: http://synscan.nss.nu/programs.php
+
+Roman Shterenzon <roman@xpert.com>
diff --git a/net/arping/pkg-plist b/net/arping/pkg-plist
new file mode 100644
index 000000000000..7c61a1c94378
--- /dev/null
+++ b/net/arping/pkg-plist
@@ -0,0 +1 @@
+sbin/arping