aboutsummaryrefslogtreecommitdiff
path: root/net/asio
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2017-07-08 22:25:27 +0000
committerBernard Spil <brnrd@FreeBSD.org>2017-07-08 22:25:27 +0000
commit7534fda603f6a8317f33381b5a06c2d5beaacf43 (patch)
tree72423f8d328edbc7c253be0c7e4ae8643a7ee6fa /net/asio
parentb4db0b0380fd41367c5ef2d4ac59207a720260ad (diff)
downloadports-7534fda603f6a8317f33381b5a06c2d5beaacf43.tar.gz
ports-7534fda603f6a8317f33381b5a06c2d5beaacf43.zip
net\asio: Update to 1.10.6
- Update to 1.10.6 (~boost 1.58) - Add patch fixing no-ssl3 build (OpenSSL 1.1, LibreSSL) - Add LICENSE_FILE (and silence warning) PR: 219924 Approved by: maintainer time-out Sponsored by: Essen DevSummit
Notes
Notes: svn path=/head/; revision=445347
Diffstat (limited to 'net/asio')
-rw-r--r--net/asio/Makefile5
-rw-r--r--net/asio/distinfo5
-rw-r--r--net/asio/files/patch-include_asio_ssl_impl_context.ipp26
3 files changed, 32 insertions, 4 deletions
diff --git a/net/asio/Makefile b/net/asio/Makefile
index a79389c5d0d5..7c4dacbda31c 100644
--- a/net/asio/Makefile
+++ b/net/asio/Makefile
@@ -2,14 +2,15 @@
# $FreeBSD$
PORTNAME= asio
-PORTVERSION= 1.10.4
-PORTREVISION= 3
+PORTVERSION= 1.10.6
CATEGORIES= net devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20(Stable)/
MAINTAINER= acm@FreeBSD.org
COMMENT= Cross-platform C++ library for network and low-level I/O programming
+LICENSE_FILE= ${WRKSRC}/LICENSE_1_0.txt
+
RUN_DEPENDS= ${LOCALBASE}/include/boost/chrono/system_clocks.hpp:devel/boost-libs
GNU_CONFIGURE= yes
diff --git a/net/asio/distinfo b/net/asio/distinfo
index 2f491d0593a2..9868e341a4c2 100644
--- a/net/asio/distinfo
+++ b/net/asio/distinfo
@@ -1,2 +1,3 @@
-SHA256 (asio-1.10.4.tar.bz2) = 313b0d69bd5fd528a6748fec2f24c56ab143310302c903efe5f0728232b7b14a
-SIZE (asio-1.10.4.tar.bz2) = 1270594
+TIMESTAMP = 1497173194
+SHA256 (asio-1.10.6.tar.bz2) = e0d71c40a7b1f6c1334008fb279e7361b32a063e020efd21e40d9d8ff037195e
+SIZE (asio-1.10.6.tar.bz2) = 1266180
diff --git a/net/asio/files/patch-include_asio_ssl_impl_context.ipp b/net/asio/files/patch-include_asio_ssl_impl_context.ipp
new file mode 100644
index 000000000000..20832a35c47a
--- /dev/null
+++ b/net/asio/files/patch-include_asio_ssl_impl_context.ipp
@@ -0,0 +1,26 @@
+--- include/asio/ssl/impl/context.ipp.orig 2015-03-23 20:28:30 UTC
++++ include/asio/ssl/impl/context.ipp
+@@ -88,7 +88,15 @@ context::context(context::method m)
+ handle_ = ::SSL_CTX_new(::SSLv2_server_method());
+ break;
+ #endif // defined(OPENSSL_NO_SSL2)
++#if defined(OPENSSL_NO_SSL3)
+ case context::sslv3:
++ case context::sslv3_client:
++ case context::sslv3_server:
++ asio::detail::throw_error(
++ asio::error::invalid_argument, "context");
++ break;
++#else // defined(OPENSSL_NO_SSL3)
++ case context::sslv3:
+ handle_ = ::SSL_CTX_new(::SSLv3_method());
+ break;
+ case context::sslv3_client:
+@@ -97,6 +105,7 @@ context::context(context::method m)
+ case context::sslv3_server:
+ handle_ = ::SSL_CTX_new(::SSLv3_server_method());
+ break;
++#endif // defined(OPENSSL_NO_SSL3)
+ case context::tlsv1:
+ handle_ = ::SSL_CTX_new(::TLSv1_method());
+ break;