aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk-g72x/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-10-23 08:13:57 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-10-23 08:13:57 +0000
commite0793a4c19f7e2ddeb12a6f7e3910498de610cdc (patch)
treedfabcf08a0526e56b114a40043a5bf377b413f47 /net/asterisk-g72x/Makefile
parent5b142575b8f32d17c5fddbc375523d06e68550f3 (diff)
downloadports-e0793a4c19f7e2ddeb12a6f7e3910498de610cdc.tar.gz
ports-e0793a4c19f7e2ddeb12a6f7e3910498de610cdc.zip
- Repocopy asterisk16 to asterisk18 and update to new version 18.0.0
- Add conflicts and flavors for version 18 to asterisk modules I maintain.
Notes
Notes: svn path=/head/; revision=553096
Diffstat (limited to 'net/asterisk-g72x/Makefile')
-rw-r--r--net/asterisk-g72x/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/net/asterisk-g72x/Makefile b/net/asterisk-g72x/Makefile
index efe675f07ddb..6716ba707e25 100644
--- a/net/asterisk-g72x/Makefile
+++ b/net/asterisk-g72x/Makefile
@@ -12,11 +12,11 @@ COMMENT= G.729 codec for Asterisk PBX
LIB_DEPENDS= libbcg729.so:audio/bcg729
-FLAVORS= asterisk16 asterisk13
+FLAVORS= asterisk16 asterisk18 asterisk13
FLAVOR?= ${FLAVORS:[1]}
asterisk13_PKGNAMEPREFIX= asterisk13-
-asterisk13_CONFLICTS_INSTALL= asterisk16-g72x
+asterisk13_CONFLICTS_INSTALL= asterisk16-g72x asterisk18-g72x
asterisk13_BUILD_DEPENDS= asterisk:net/asterisk13
asterisk13_RUN_DEPENDS= asterisk:net/asterisk13
.if ${FLAVOR} == asterisk13
@@ -24,13 +24,21 @@ CONFIGURE_ARGS+= --with-asterisk130
.endif
asterisk16_PKGNAMEPREFIX= asterisk16-
-asterisk16_CONFLICTS_INSTALL= asterisk13-g72x
+asterisk16_CONFLICTS_INSTALL= asterisk13-g72x asterisk18-g72x
asterisk16_BUILD_DEPENDS= asterisk:net/asterisk16
asterisk16_RUN_DEPENDS= asterisk:net/asterisk16
.if ${FLAVOR} == asterisk16
CONFIGURE_ARGS+= --with-asterisk160
.endif
+asterisk18_PKGNAMEPREFIX= asterisk18-
+asterisk18_CONFLICTS_INSTALL= asterisk13-g72x asterisk16-g72x
+asterisk18_BUILD_DEPENDS= asterisk:net/asterisk18
+asterisk18_RUN_DEPENDS= asterisk:net/asterisk18
+.if ${FLAVOR} == asterisk18
+CONFIGURE_ARGS+= --with-asterisk160
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-bcg729
USES= autoreconf compiler:c11 libtool localbase tar:bzip2