aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk13
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-07-18 18:01:29 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-07-18 18:01:29 +0000
commitc70107337de9e35613cdb602bbe92a3d3cbbbb8f (patch)
tree94535242b0813efc96e125d9e0feae956c6ad66c /net/asterisk13
parent4d6a906c0fed661c1b32eddc42a941b175fa7605 (diff)
downloadports-c70107337de9e35613cdb602bbe92a3d3cbbbb8f.tar.gz
ports-c70107337de9e35613cdb602bbe92a3d3cbbbb8f.zip
FreeBSD's regexec() libc function is more restrictive than the linux
one and will not accept an empty expression. Add patch (from PR) to fix this problem. PR: 211187 Submitted by: Dmitry Vagin <daemon.hammer at ya.ru>
Notes
Notes: svn path=/head/; revision=418726
Diffstat (limited to 'net/asterisk13')
-rw-r--r--net/asterisk13/Makefile2
-rw-r--r--net/asterisk13/files/patch-res_res__pjsip_pjsip__cli.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index b5fde8fd4d36..6a441b9349e3 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -2,7 +2,7 @@
PORTNAME= asterisk
PORTVERSION= 13.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/%SUBDIR%/:DEFAULT,g729
MASTER_SITE_SUBDIR= asterisk/ \
diff --git a/net/asterisk13/files/patch-res_res__pjsip_pjsip__cli.c b/net/asterisk13/files/patch-res_res__pjsip_pjsip__cli.c
new file mode 100644
index 000000000000..f1d6aa4819cc
--- /dev/null
+++ b/net/asterisk13/files/patch-res_res__pjsip_pjsip__cli.c
@@ -0,0 +1,11 @@
+--- res/res_pjsip/pjsip_cli.c.orig 2016-05-13 17:41:41 UTC
++++ res/res_pjsip/pjsip_cli.c
+@@ -172,7 +172,7 @@ char *ast_sip_cli_traverse_objects(struc
+ }
+ regex = a->argv[4];
+ } else {
+- regex = "";
++ regex = ".";
+ }
+
+ if (cmd == CLI_GENERATE