aboutsummaryrefslogtreecommitdiff
path: root/net/belle-sip
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-16 19:00:51 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-16 19:00:51 +0000
commit0cb631680c0db01480dcd8c34c0d9e27567e9bc0 (patch)
tree72689a3dcc684e3239e97736f1c203de018806a0 /net/belle-sip
parent18641c2a3611b33d237053275e00858f07cabb1e (diff)
downloadports-0cb631680c0db01480dcd8c34c0d9e27567e9bc0.tar.gz
ports-0cb631680c0db01480dcd8c34c0d9e27567e9bc0.zip
- Updates to the Linphone stack: Belle-sip 1.4.0, oRTP 0.24.1,
Mediastreamer 2.11.1, Linphone 3.8.1 - Switch to PolarSSL 1.3.x to enable instant messaging encryption - SRTP/ZRTP support has been moved from oRTP to Mediastreamer Notable enhancements in this release: - Fullscreen mode - Hang up button in the video window - Wizard for audio/video settings - Arabic translation - Support RTP/AVPF (RFC4585) with VP8 codec: this feature allows transmission error recovery for video, which greatly enhances the video quality over unreliable links
Notes
Notes: svn path=/head/; revision=384119
Diffstat (limited to 'net/belle-sip')
-rw-r--r--net/belle-sip/Makefile21
-rw-r--r--net/belle-sip/distinfo4
-rw-r--r--net/belle-sip/files/patch-configure16
-rw-r--r--net/belle-sip/files/patch-src-belle_sip_headers_impl.c35
-rw-r--r--net/belle-sip/files/patch-src_dns.c2
-rw-r--r--net/belle-sip/pkg-plist1
6 files changed, 54 insertions, 25 deletions
diff --git a/net/belle-sip/Makefile b/net/belle-sip/Makefile
index d2ced60f79c1..76d9f16d7bc2 100644
--- a/net/belle-sip/Makefile
+++ b/net/belle-sip/Makefile
@@ -1,14 +1,13 @@
# $FreeBSD$
PORTNAME= belle-sip
-PORTVERSION= 1.3.0
-PORTREVISION= 2
+PORTVERSION= 1.4.0
CATEGORIES= net java
MASTER_SITES= SAVANNAH/linphone/${PORTNAME}/:source1 \
http://www.antlr3.org/download/:source2
-DISTFILES= belle-sip-1.3.0.tar.gz:source1 \
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:source1 \
antlr-3.4-complete.jar:source2
-EXTRACT_ONLY= belle-sip-1.3.0.tar.gz
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= bofh@FreeBSD.org
COMMENT= Belle-sip is a SIP (RFC3261) implementation written in C
@@ -21,7 +20,8 @@ LIB_DEPENDS= libantlr3c.so:${PORTSDIR}/devel/libantlr3c
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --disable-tests
+CONFIGURE_ARGS= --disable-silent-rules --disable-strict --disable-tests \
+ --with-antlr=${LOCALBASE}
INSTALL_TARGET= install-strip
USES= compiler:c11 gmake libtool pathfix
USE_JAVA= yes
@@ -33,20 +33,13 @@ OPTIONS_DEFINE= POLARSSL
OPTIONS_DEFAULT=POLARSSL
POLARSSL_CONFIGURE_ENABLE= tls
-POLARSSL_LIB_DEPENDS= libpolarssl.so:${PORTSDIR}/security/polarssl
+POLARSSL_LIB_DEPENDS= libpolarssl.so.8:${PORTSDIR}/security/polarssl13
post-extract:
@${CP} ${DISTDIR}/antlr-3.4-complete.jar ${WRKDIR}/antlr-complete.jar
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|%%WRKDIR%%|${WRKDIR}|' -e 's|-lrt||' \
${WRKSRC}/configure
-.if ${CHOSEN_COMPILER_TYPE} == clang && (${OSVERSION} < 902512 || (${OSVERSION} >= 1000000 && ${OSVERSION} < 1000707))
- @${REINPLACE_CMD} 's, -fms-extensions,,' ${WRKSRC}/configure
-.endif
- @${REINPLACE_CMD} -e 's|-timezone||' \
- ${WRKSRC}/src/belle_sip_headers_impl.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/belle-sip/distinfo b/net/belle-sip/distinfo
index 65601a0f7299..5ba1e89427fe 100644
--- a/net/belle-sip/distinfo
+++ b/net/belle-sip/distinfo
@@ -1,4 +1,4 @@
-SHA256 (belle-sip-1.3.0.tar.gz) = 50f0106903bdf67fcbc674dd6b3ec2930d5a5e735d9ba70dbe21f4bc76f08091
-SIZE (belle-sip-1.3.0.tar.gz) = 665281
+SHA256 (belle-sip-1.4.0.tar.gz) = fffae80a4376125c17e77c2451ff8b01e28fedcc3219c7dd027051b6f9769dd3
+SIZE (belle-sip-1.4.0.tar.gz) = 742966
SHA256 (antlr-3.4-complete.jar) = 9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7
SIZE (antlr-3.4-complete.jar) = 2388361
diff --git a/net/belle-sip/files/patch-configure b/net/belle-sip/files/patch-configure
index 629d481f1937..1ccfa2118654 100644
--- a/net/belle-sip/files/patch-configure
+++ b/net/belle-sip/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig
+--- configure.orig 2015-03-11 16:44:12 UTC
+++ configure
-@@ -15655,10 +15655,10 @@
+@@ -16787,10 +16787,10 @@ libresolv_have_res_get_servers=no
resolv_h_hav_res_ndestroy=no
LIBS_save=$LIBS
@@ -12,17 +12,17 @@
#include <resolv.h>
int
main ()
-@@ -15683,7 +15683,8 @@
+@@ -16814,7 +16814,8 @@ fi
+ rm -f core conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
- ac_fn_c_check_decl "$LINENO" "res_ndestroy
-- " "ac_cv_have_decl_res_ndestroy___" "#include <resolv.h>
-+ " "ac_cv_have_decl_res_ndestroy___" "#include <netinet/in.h>
+-ac_fn_c_check_decl "$LINENO" "res_ndestroy" "ac_cv_have_decl_res_ndestroy" "#include <resolv.h>
++ac_fn_c_check_decl "$LINENO" "res_ndestroy" "ac_cv_have_decl_res_ndestroy" "#include <netinet/in.h>
+#include <resolv.h>
"
- if test "x$ac_cv_have_decl_res_ndestroy___" = xyes; then :
+ if test "x$ac_cv_have_decl_res_ndestroy" = xyes; then :
resolv_h_hav_res_ndestroy=yes
-@@ -15748,17 +15749,11 @@
+@@ -16877,17 +16878,11 @@ fi
if test $ANTLR = "no" ; then
diff --git a/net/belle-sip/files/patch-src-belle_sip_headers_impl.c b/net/belle-sip/files/patch-src-belle_sip_headers_impl.c
new file mode 100644
index 000000000000..c71bb9a5e56f
--- /dev/null
+++ b/net/belle-sip/files/patch-src-belle_sip_headers_impl.c
@@ -0,0 +1,35 @@
+--- src/belle_sip_headers_impl.c.orig 2015-01-20 10:39:04 UTC
++++ src/belle_sip_headers_impl.c
+@@ -1663,7 +1663,6 @@ BELLESIP_EXPORT time_t belle_sip_header_
+ char tmp2[16] ={0};
+ int i,j;
+ time_t seconds;
+- time_t adjust_timezone;
+
+
+ /* time headers are in GMT as spec says */
+@@ -1685,22 +1684,12 @@ BELLESIP_EXPORT time_t belle_sip_header_
+ return (time_t)-1;
+ success:
+ ret.tm_isdst=0;
+-
+-#if TARGET_IPHONE_SIMULATOR
+- /* 'timezone' is buggy on iOS simulator, use the timegm() function to convert to UTC timestamp
+- and discard the adjust timezone value */
+ seconds = timegm(&ret);
+- adjust_timezone = 0;
+-#else
+- seconds = mktime(&ret);
+- adjust_timezone = timezone;
+-#endif
+-
+ if (seconds==(time_t)-1){
+- belle_sip_error("mktime() failed: %s",strerror(errno));
++ belle_sip_error("timegm() failed: %s",strerror(errno));
+ return (time_t)-1;
+ }
+- return seconds-adjust_timezone;
++ return seconds;
+ }
+
+ BELLESIP_EXPORT void belle_sip_header_date_set_time(belle_sip_header_date_t *obj, const time_t *utc_time){
diff --git a/net/belle-sip/files/patch-src_dns.c b/net/belle-sip/files/patch-src_dns.c
index 3b05417a1059..1d489299c5cd 100644
--- a/net/belle-sip/files/patch-src_dns.c
+++ b/net/belle-sip/files/patch-src_dns.c
@@ -4,7 +4,7 @@
union res_sockaddr_union addresses[3];
int i,error;
-+ bzero(&res, sizeof(res));
++ memset(&res, 0, sizeof(res));
if ((error = res_ninit(&res))) {
return error;
}
diff --git a/net/belle-sip/pkg-plist b/net/belle-sip/pkg-plist
index eb1faa980b68..e00d8f5519bb 100644
--- a/net/belle-sip/pkg-plist
+++ b/net/belle-sip/pkg-plist
@@ -1,6 +1,7 @@
include/belle-sip/auth-helper.h
include/belle-sip/belle-sdp.h
include/belle-sip/belle-sip.h
+include/belle-sip/bodyhandler.h
include/belle-sip/defs.h
include/belle-sip/dialog.h
include/belle-sip/dict.h