aboutsummaryrefslogtreecommitdiff
path: root/net/bird-devel/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2011-11-08 09:44:29 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2011-11-08 09:44:29 +0000
commit7b2e3e4ebd39e4dada7413fb0b39d60603405194 (patch)
treec7061c48c507bbb6b86d7d5b5b38e3ab43dbc691 /net/bird-devel/Makefile
parentf70f6f5568289b7d49e18c77792626850d45e272 (diff)
downloadports-7b2e3e4ebd39e4dada7413fb0b39d60603405194.tar.gz
ports-7b2e3e4ebd39e4dada7413fb0b39d60603405194.zip
* New port:
This is development version of net/bird dynamic routing software. It provides ALPHA support for the following: - VPNv4 RR - LDP - L3VPN Submitted by: melifaro
Notes
Notes: svn path=/head/; revision=285285
Diffstat (limited to 'net/bird-devel/Makefile')
-rw-r--r--net/bird-devel/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/net/bird-devel/Makefile b/net/bird-devel/Makefile
new file mode 100644
index 000000000000..ab98e9de496d
--- /dev/null
+++ b/net/bird-devel/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: bird
+# Date created: 8 November 2011
+# Whom: Alexander V. Chernikov <melifaro@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bird
+PORTVERSION= 20111107
+CATEGORIES= net
+MASTER_SITES= http://bird.mpls.in/distfiles/bird/
+PKGNAMESUFFIX= -devel
+
+MAINTAINER= melifaro@ipfw.ru
+COMMENT= Dynamic IP routing daemon (devel version)
+
+CONFLICTS= bird-[0-9]*
+
+USE_BISON= build
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-mpls
+
+OPTIONS= KMPLS "Enable kernel MPLS support" Off
+
+MAKE_JOBS_UNSAFE= yes
+
+USE_RC_SUBR= bird
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_KMPLS)
+CONFIGURE_ARGS+= --enable-kmpls
+.endif
+
+post-install:
+ @if [ ! -f ${PREFIX}/etc/bird.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/bird.conf.example ${PREFIX}/etc/bird.conf ; \
+ ${CHMOD} 0640 ${PREFIX}/etc/bird.conf ; \
+ fi
+ @${ECHO_MSG}
+ @${ECHO_MSG} =====================================================================
+ @${ECHO_MSG}
+ @${ECHO_MSG} " WARNING: Please take a look on kern/134931"
+ @${ECHO_MSG} " WARNING: before using multiple fibs!"
+ @${ECHO_MSG} " 8.2-STABLE kernel patch available here:"
+ @${ECHO_MSG} " http://static.ipfw.ru/patches/rtsock_82S-20110725.diff"
+ @${ECHO_MSG}
+ @${ECHO_MSG} =====================================================================
+ @${ECHO_MSG}
+
+.include <bsd.port.post.mk>