aboutsummaryrefslogtreecommitdiff
path: root/net/boinc-client/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-27 09:36:57 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-27 09:36:57 +0000
commit49948a095f2cb1dbd0b2f9563bff135be8351143 (patch)
tree28575bf22e4245e43bdbe863009c39f609678d40 /net/boinc-client/Makefile
parent243c0fd56d0b72bb0b973f756a6f4198d93255e7 (diff)
downloadports-49948a095f2cb1dbd0b2f9563bff135be8351143.tar.gz
ports-49948a095f2cb1dbd0b2f9563bff135be8351143.zip
net/boinc-client: Fix to detect virtualbox again
The virtualbox path detection code has been patched to work on FreeBSD. The PR submission was modified to avoid hardcoding /usr/local. PR: 188710 Submitted by: Lawrence Chen
Notes
Notes: svn path=/head/; revision=363031
Diffstat (limited to 'net/boinc-client/Makefile')
-rw-r--r--net/boinc-client/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index ae7d1b97c7dc..9ed262437be8 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -3,7 +3,7 @@
PORTNAME= boinc-client
PORTVERSION= 7.2.33
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL} \
ftp://rene-ladan.nl/pub/distfiles/
@@ -124,6 +124,10 @@ post-extract:
${WRKSRC}/zip/zip/zip.c ${WRKSRC}/zip/zip/zipfile.c \
${WRKSRC}/zip/zip/zipup.c
+post-patch:
+ ${REINPLACE_CMD} -e 's|@PREFIX@|${PREFIX}|' \
+ ${WRKSRC}/client/hostinfo_unix.cpp
+
pre-configure:
(cd ${WRKSRC} ; ./_autosetup)