aboutsummaryrefslogtreecommitdiff
path: root/net/boinc-client
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-08-27 22:07:56 +0000
committerRene Ladan <rene@FreeBSD.org>2013-08-27 22:07:56 +0000
commit8114a2eaaefe446f4ece45b4bcf94ad6d4ce677c (patch)
tree8fdcafe66ea9b6a914851ac33d9d3a4d54ef2765 /net/boinc-client
parent30fa6c870e6be378a82b163ded29c365ad90de0c (diff)
downloadports-8114a2eaaefe446f4ece45b4bcf94ad6d4ce677c.tar.gz
ports-8114a2eaaefe446f4ece45b4bcf94ad6d4ce677c.zip
- Move handling of X11 option down, so that the two handlers for the
MANAGER optino can be merged [1] - Use new LIB_DEPENDS syntax PR: ports/176724 [1] (part) Submitted by: Andrey Simonenko <simon@comsys.ntu-kpi.kiev.ua>
Notes
Notes: svn path=/head/; revision=325492
Diffstat (limited to 'net/boinc-client')
-rw-r--r--net/boinc-client/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index 5a7512055c14..20f5920c1a0e 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -60,24 +60,12 @@ BROKEN= Does not install on ia64, powerpc, or sparc64
.if ${PORT_OPTIONS:MMANAGER}
PORT_OPTIONS+= CLIENT X11
-.endif
-
-.if ${PORT_OPTIONS:MX11}
-USE_GL= glut
-USE_XORG+= xmu xi
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
-PLIST_SUB+= X11=""
-.else
-PLIST_SUB+= X11="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMANAGER}
USE_XORG+= x11
USE_WX= 2.8+
USES+= iconv
WX_CONF_ARGS= absolute
-LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify \
- sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS+= libnotify.so:${PORTSDIR}/devel/libnotify \
+ libsqlite3.so:${PORTSDIR}/databases/sqlite3
CONFIGURE_ARGS+=--with-sqlite3-prefix=${LOCALBASE}
. if ${OSVERSION} < 900506 || (${OSVERSION} >= 1000000 && ${OSVERSION} < 1000002)
CPPFLAGS+= -DNO_PER_THREAD_LOCALE
@@ -92,7 +80,7 @@ SUB_LIST+= OPTION_MANAGER=""
.if ${PORT_OPTIONS:MCLIENT}
USE_RC_SUBR= boinc-client
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
PLIST_SUB+= BOINC_CLIENT=""
SUB_LIST+= OPTION_NO_GUI_RPC=${PORT_OPTIONS:MNO_GUI_RPC:S/^NO_GUI_RPC$/--no_gui_rpc/} \
@@ -132,6 +120,15 @@ SUB_LIST+= OPTION_USER=""
CONFIGURE_ARGS+=--enable-optimize
.endif
+.if ${PORT_OPTIONS:MX11}
+USE_GL= glut
+USE_XORG+= xmu xi
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
+PLIST_SUB+= X11=""
+.else
+PLIST_SUB+= X11="@comment "
+.endif
+
PORT_OPTIONS:= ${PORT_OPTIONS:O:u}
post-patch: