aboutsummaryrefslogtreecommitdiff
path: root/net/bosh-bootloader
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-01-27 19:02:01 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-01-27 19:02:01 +0000
commit969b6ba3cf3c29677812f054eb0d92449ffc440e (patch)
tree467d37335836db9f62d4f432de803046ec5897cc /net/bosh-bootloader
parentc379c6fe6aa0ea4e7806a57daa3a905e63fa36f4 (diff)
downloadports-969b6ba3cf3c29677812f054eb0d92449ffc440e.tar.gz
ports-969b6ba3cf3c29677812f054eb0d92449ffc440e.zip
net/bosh-{bootloader,cli}: New ports for the BOSH CLI v2
The new BOSH CLI is comprised of two executables: `bbl` and `bosh`. They replace the previous version of the CLI (sysutils/rubygem-bosh_cli). Sponsored by: Pivotal
Notes
Notes: svn path=/head/; revision=460141
Diffstat (limited to 'net/bosh-bootloader')
-rw-r--r--net/bosh-bootloader/Makefile25
-rw-r--r--net/bosh-bootloader/distinfo3
-rw-r--r--net/bosh-bootloader/pkg-descr6
3 files changed, 34 insertions, 0 deletions
diff --git a/net/bosh-bootloader/Makefile b/net/bosh-bootloader/Makefile
new file mode 100644
index 000000000000..d118ace01874
--- /dev/null
+++ b/net/bosh-bootloader/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= bosh-bootloader
+PORTVERSION= 6.0.0
+CATEGORIES= net sysutils
+
+MAINTAINER= dumbbell@FreeBSD.org
+COMMENT= CLI for standing up CloudFoundry or Concourse on an IAAS
+
+LICENSE= APACHE20
+
+USE_GITHUB= yes
+GH_TUPLE= cloudfoundry:bosh-bootloader:v${PORTVERSION}
+
+USES= go tar:xz
+
+GO_PKGNAME= github.com/cloudfoundry/bosh-bootloader
+GO_TARGET= github.com/cloudfoundry/bosh-bootloader/bbl
+
+PLIST_FILES= bin/bbl
+
+post-patch:
+ ${REINPLACE_CMD} -E -e 's|(Version = )"dev"|\1"${PORTVERSION}"|' ${WRKSRC}/bbl/main.go
+
+.include <bsd.port.mk>
diff --git a/net/bosh-bootloader/distinfo b/net/bosh-bootloader/distinfo
new file mode 100644
index 000000000000..531932ba7c40
--- /dev/null
+++ b/net/bosh-bootloader/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1517077398
+SHA256 (cloudfoundry-bosh-bootloader-6.0.0-v6.0.0_GH0.tar.gz) = 6390b292a60278c5fbeb60582405afd146c7eefc8a5e0a05215b9325a6e15e95
+SIZE (cloudfoundry-bosh-bootloader-6.0.0-v6.0.0_GH0.tar.gz) = 4113792
diff --git a/net/bosh-bootloader/pkg-descr b/net/bosh-bootloader/pkg-descr
new file mode 100644
index 000000000000..1ef34b184e95
--- /dev/null
+++ b/net/bosh-bootloader/pkg-descr
@@ -0,0 +1,6 @@
+This is a command line utility for standing up a CloudFoundry or
+Concourse installation on an IAAS. This CLI is currently under heavy
+development, and the initial goal is to support bootstrapping a
+CloudFoundry installation on AWS.
+
+WWW: https://github.com/cloudfoundry/bosh-bootloader