aboutsummaryrefslogtreecommitdiff
path: root/net/bsdec2-image-upload
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-22 10:17:26 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-22 10:17:26 +0000
commite0d4a5b85188e9598b8b1948b8d579d5a35b35f2 (patch)
treeea3812f85474ed02770b8bd04dab440a13285c77 /net/bsdec2-image-upload
parent515958e3f1cd02e71b93fb005e3188abc5f7508b (diff)
downloadports-e0d4a5b85188e9598b8b1948b8d579d5a35b35f2.tar.gz
ports-e0d4a5b85188e9598b8b1948b8d579d5a35b35f2.zip
net/bsdec2-image-upload: fix build on GCC architectures
-W\#warnings is incorrect for GCC: cc1: error: -Werror=#warnings: No option -W#warnings MFH: 2020Q3 (fix build blanket)
Notes
Notes: svn path=/head/; revision=542847
Diffstat (limited to 'net/bsdec2-image-upload')
-rw-r--r--net/bsdec2-image-upload/Makefile10
-rw-r--r--net/bsdec2-image-upload/files/extra-patch-Makefile10
2 files changed, 18 insertions, 2 deletions
diff --git a/net/bsdec2-image-upload/Makefile b/net/bsdec2-image-upload/Makefile
index 6d1edacba0a2..8b9aab263471 100644
--- a/net/bsdec2-image-upload/Makefile
+++ b/net/bsdec2-image-upload/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-USES= ssl tar:tgz uidfix
+USES= compiler ssl tar:tgz uidfix
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
@@ -23,4 +23,10 @@ MAKE_ARGS+= BINDIR=${PREFIX}/bin
PLIST_FILES= bin/bsdec2-image-upload
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/bsdec2-image-upload/files/extra-patch-Makefile b/net/bsdec2-image-upload/files/extra-patch-Makefile
new file mode 100644
index 000000000000..fd2aeeaa7c61
--- /dev/null
+++ b/net/bsdec2-image-upload/files/extra-patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2020-07-22 09:29:11 UTC
++++ Makefile
+@@ -2,7 +2,6 @@ PROG= bsdec2-image-upload
+ SRCS= main.c
+ MAN =
+ WARNS ?= 3
+-CFLAGS += -Wno-error=\#warnings
+ BINDIR ?= /usr/local/bin
+ LDADD += -lcrypto -lssl
+