aboutsummaryrefslogtreecommitdiff
path: root/net/citrix_ica/Makefile
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-01-25 15:11:20 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-01-25 15:11:20 +0000
commit203ff805e997a31fe36899ed63c786f9b8b5c3ce (patch)
tree50500441dade69e0f2f52990c0135e2ac371251e /net/citrix_ica/Makefile
parent6122ecf448afe4ef7db6837b47bcb904370e93e0 (diff)
downloadports-203ff805e997a31fe36899ed63c786f9b8b5c3ce.tar.gz
ports-203ff805e997a31fe36899ed63c786f9b8b5c3ce.zip
- Use SUB_FILES/LIST in lieu of sed
- No PORTREVISION bump needed PR: ports/143103 Submitted by: Sevan Janiyan <venture37 geeklan.co.uk>
Notes
Notes: svn path=/head/; revision=248557
Diffstat (limited to 'net/citrix_ica/Makefile')
-rw-r--r--net/citrix_ica/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/net/citrix_ica/Makefile b/net/citrix_ica/Makefile
index 77a2d5fb3bae..68a4f15b4068 100644
--- a/net/citrix_ica/Makefile
+++ b/net/citrix_ica/Makefile
@@ -35,6 +35,9 @@ PLIST_SUB+= HAVE_ICA_CERTS="" ICA_CERTS="${ICA_CERTS}" CERTDIR="${CERTDIR}"
PLIST_SUB+= HAVE_ICA_CERTS="@comment "
.endif
+SUB_FILES= wfcmgr wfica
+SUB_LIST= CDIR=${CDIR}
+
.include <bsd.port.pre.mk>
.if defined(BATCH) || defined(PACKAGE_BUILDING)
@@ -76,13 +79,9 @@ do-install:
${ECHO} "-----------------------------------------------------------" ; \
${FALSE} ; \
fi
- ${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfcmgr \
- > ${WRKSRC}/wfcmgr.x
- ${SED} s%DESTINATION%${CDIR}% < ${FILESDIR}/wfica \
- > ${WRKSRC}/wfica.x
cd ${WRKSRC} && ${SH} -c './setupwfc'
- ${INSTALL_SCRIPT} ${WRKSRC}/wfcmgr.x ${PREFIX}/bin/wfcmgr
- ${INSTALL_SCRIPT} ${WRKSRC}/wfica.x ${PREFIX}/bin/wfica
+ ${INSTALL_SCRIPT} ${WRKDIR}/wfcmgr ${PREFIX}/bin/wfcmgr
+ ${INSTALL_SCRIPT} ${WRKDIR}/wfica ${PREFIX}/bin/wfica
# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
.if defined(ICA_CERTS)