aboutsummaryrefslogtreecommitdiff
path: root/net/cryptcat
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-30 13:21:29 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-30 13:21:29 +0000
commitbf51c6f124f9deae54869dfce16d78d174a5f0d9 (patch)
treedbf899c5ebd9c653e4daea5fc0f422df87136eff /net/cryptcat
parent0524010472c452e6369863c388f73b1fcb235246 (diff)
downloadports-bf51c6f124f9deae54869dfce16d78d174a5f0d9.tar.gz
ports-bf51c6f124f9deae54869dfce16d78d174a5f0d9.zip
- Update from 20031202 to 1.2.1
- Bump PORTEPOCH - Update MASTER_SITE and WWW (project moved to sourceforge) - Remove two patches that contained CR/LF's - Add two patches (invoked by CR/LF problematic) - Pass maintainership to submitter PR: 88134 Submitted by: Gabor Kovesdan <gabor.kovesdan@t-hosting.hu>
Notes
Notes: svn path=/head/; revision=146748
Diffstat (limited to 'net/cryptcat')
-rw-r--r--net/cryptcat/Makefile13
-rw-r--r--net/cryptcat/distinfo4
-rw-r--r--net/cryptcat/files/patch-Makefile (renamed from net/cryptcat/files/patch-aa)27
-rw-r--r--net/cryptcat/files/patch-farm9crypt.cc (renamed from net/cryptcat/files/patch-ab)18
-rw-r--r--net/cryptcat/files/patch-netcat.c11
-rw-r--r--net/cryptcat/pkg-descr2
6 files changed, 33 insertions, 42 deletions
diff --git a/net/cryptcat/Makefile b/net/cryptcat/Makefile
index 48cb6ff4d289..db2ac7f7e644 100644
--- a/net/cryptcat/Makefile
+++ b/net/cryptcat/Makefile
@@ -6,15 +6,18 @@
#
PORTNAME= cryptcat
-PORTVERSION= 20031202
+PORTVERSION= 1.2.1
+PORTEPOCH= 1
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_GENTOO}
-MASTER_SITE_SUBDIR= distfiles
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-unix-${PORTVERSION}
+EXTRACT_SUFX= .tar
-MAINTAINER= ports@oven.org
+MAINTAINER= gkovesdan@t-hosting.hu
COMMENT= Standard netcat enhanced with twofish encryption
+WRKSRC= ${WRKDIR}/unix
ALL_TARGET= freebsd
PLIST_FILES= bin/cryptcat
diff --git a/net/cryptcat/distinfo b/net/cryptcat/distinfo
index df962af26496..eade4f76e8ac 100644
--- a/net/cryptcat/distinfo
+++ b/net/cryptcat/distinfo
@@ -1,2 +1,2 @@
-MD5 (cryptcat_20031202.tar.gz) = bcbe1d6b26089f94cdb95e5823556289
-SIZE (cryptcat_20031202.tar.gz) = 67004
+MD5 (cryptcat-unix-1.2.1.tar) = fc4afff350f3dd5e4fe51b0dd01a8e21
+SIZE (cryptcat-unix-1.2.1.tar) = 190464
diff --git a/net/cryptcat/files/patch-aa b/net/cryptcat/files/patch-Makefile
index b56c7dd0143d..ed094447042e 100644
--- a/net/cryptcat/files/patch-aa
+++ b/net/cryptcat/files/patch-Makefile
@@ -1,23 +1,21 @@
---- Makefile.orig Wed Sep 20 05:25:36 2000
-+++ Makefile Wed Sep 4 19:31:33 2002
-@@ -10,13 +10,13 @@
+--- Makefile.orig Tue May 22 21:06:42 2001
++++ Makefile Fri Oct 28 15:07:46 2005
+@@ -10,13 +10,11 @@
# debugging
# DFLAGS = -DTEST -DDEBUG
DFLAGS = -DGAPING_SECURITY_HOLE
-CFLAGS = -O
-+CFLAGS ?= -O
XFLAGS = # xtra cflags, set by systype targets
XLIBS = # xtra libs if necessary?
# -Bstatic for sunos, -static for gcc, etc. You want this, trust me.
STATIC =
-CC = cc $(CFLAGS)
-LD = $(CC) -s # linker; defaults to stripped executables
-+CXX ?= c++
+LD = $(CXX) -s # linker; defaults to stripped executables
o = o # object extension
ALL = cryptcat
-@@ -28,8 +28,11 @@
+@@ -28,8 +26,11 @@
### HARD TARGETS
@@ -26,30 +24,21 @@
+netcat.o:
+ $(CC) $(CFLAGS) -c netcat.c
+
-+cryptcat: netcat.o farm9crypt.o twofish2.o
++cryptcat: netcat.o farm9crypt.o twofish2.o
+ $(LD) $(CFLAGS) $(DFLAGS) $(XFLAGS) $(STATIC) -o cryptcat netcat.o farm9crypt.o twofish2.o $(XLIBS)
nc-dos:
@echo "DOS?! Maybe someday, but not now"
-@@ -82,7 +85,7 @@
-
- # virtually the same as netbsd/bsd44lite/whatever
- freebsd:
-- make -e $(ALL) $(MFLAGS) XFLAGS='-DFREEBSD' STATIC=-static
-+ make -e $(ALL) $(MFLAGS) XFLAGS='-DFREEBSD -DGAPING_SECURITY_HOLE -DTELNET' STATIC=-static
-
- bsdi:
- make -e $(ALL) $(MFLAGS) XFLAGS='-DBSDI' STATIC=-Bstatic
-@@ -111,10 +114,10 @@
+@@ -113,10 +114,10 @@
make -e $(ALL) $(MFLAGS) XFLAGS='-DNEXT' STATIC=-Bstatic
farm9crypt.o: farm9crypt.cc farm9crypt.h
- ${CC} -c farm9crypt.cc
-+ ${CXX} ${CXXFLAGS} -c farm9crypt.cc
++ ${CC} ${CFLAGS} -c farm9crypt.cc
twofish2.o: twofish2.cc twofish2.h
- ${CC} -c twofish2.cc
-+ ${CXX} ${CXXFLAGS} -c twofish2.cc
++ ${CC} ${CFLAGS} -c twofish2.cc
# start with this for a new architecture, and see what breaks.
generic:
diff --git a/net/cryptcat/files/patch-ab b/net/cryptcat/files/patch-farm9crypt.cc
index fda7a69c4da9..f7484ee1b12d 100644
--- a/net/cryptcat/files/patch-ab
+++ b/net/cryptcat/files/patch-farm9crypt.cc
@@ -1,10 +1,10 @@
---- farm9crypt.cc.orig Mon Oct 2 05:08:44 2000
-+++ farm9crypt.cc Wed Sep 4 19:27:56 2002
-@@ -21,6 +21,7 @@
- #include <sys/types.h> // suggested by several people -- for OpenBSD, FreeBSD compiles
- #include <sys/socket.h> /* basics, SO_ and AF_ defs, sockaddr, ... */
- #include <stdlib.h>
+--- farm9crypt.cc.orig Sat Dec 18 05:34:27 2004
++++ farm9crypt.cc Sun Oct 30 07:45:05 2005
+@@ -23,6 +23,7 @@
+ #include <sys/types.h> // suggested by several people -- for OpenBSD, FreeBSD compiles
+ #include <sys/socket.h> /* basics, SO_ and AF_ defs, sockaddr, ... */
+ #include <stdlib.h>
+#include <string.h>
- #else
- #include <fcntl.h>
- #include <io.h>
+ #else
+ #include <fcntl.h>
+ #include <io.h>
diff --git a/net/cryptcat/files/patch-netcat.c b/net/cryptcat/files/patch-netcat.c
index fcdcaa9fc56b..b3a67854b99b 100644
--- a/net/cryptcat/files/patch-netcat.c
+++ b/net/cryptcat/files/patch-netcat.c
@@ -1,6 +1,6 @@
---- netcat.c.orig Wed Nov 6 13:42:04 2002
-+++ netcat.c Wed Nov 6 13:47:27 2002
-@@ -45,9 +45,6 @@
+--- netcat.c.orig Tue Oct 18 19:42:05 2005
++++ netcat.c Sun Oct 30 07:47:37 2005
+@@ -48,9 +48,6 @@
#else
#include <malloc.h>
#endif
@@ -10,17 +10,16 @@
/* have to do this *before* including types.h. xxx: Linux still has it wrong */
#ifdef FD_SETSIZE /* should be in types.h, butcha never know. */
-@@ -55,6 +52,12 @@
+@@ -58,6 +55,12 @@
#endif /* fd's, something is horribly wrong! */
#define FD_SETSIZE 16 /* <-- this'll give us a long anyways, wtf */
#include <sys/types.h> /* *now* do it. Sigh, this is broken */
+#ifdef __FreeBSD__
+#include <inttypes.h>
+#endif
-+#ifdef HAVE_SELECT_H /* random SV variants need this */
++#ifdef HAVE_SELECT_H /* random SV variants need this */
+#include <sys/select.h>
+#endif
#ifdef HAVE_RANDOM /* aficionados of ?rand48() should realize */
#define SRAND srandom /* that this doesn't need *strong* random */
-
diff --git a/net/cryptcat/pkg-descr b/net/cryptcat/pkg-descr
index aaa436cc3c62..e6338d0abebb 100644
--- a/net/cryptcat/pkg-descr
+++ b/net/cryptcat/pkg-descr
@@ -15,6 +15,6 @@ same thing. However, in this case the data transferred is encrypted.
For more information about netcat see net/netcat port.
-WWW: http://farm9.com/content/Free_Tools/Cryptcat/
+WWW: http://sourceforge.net/projects/cryptcat/
Roman Shterenzon <roman@xpert.com>