aboutsummaryrefslogtreecommitdiff
path: root/net/dgd-lpmud
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-04-04 04:46:50 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-04-04 04:46:50 +0000
commit1f58d857f6fc2c42910fe968cccd8b25ae453057 (patch)
tree670c98eafac41a75d6e9f37a2e963e97193c9766 /net/dgd-lpmud
parent70a186cf01692c96b4078fd444db78f993ec8593 (diff)
downloadports-1f58d857f6fc2c42910fe968cccd8b25ae453057.tar.gz
ports-1f58d857f6fc2c42910fe968cccd8b25ae453057.zip
. The main dgd port already creates the 'mud' user and group, so don't
repeat that in the pkg-{de}install scripts here.
Notes
Notes: svn path=/head/; revision=252177
Diffstat (limited to 'net/dgd-lpmud')
-rw-r--r--net/dgd-lpmud/Makefile3
-rw-r--r--net/dgd-lpmud/pkg-deinstall15
-rw-r--r--net/dgd-lpmud/pkg-install37
3 files changed, 0 insertions, 55 deletions
diff --git a/net/dgd-lpmud/Makefile b/net/dgd-lpmud/Makefile
index 9d65199c4c82..105c648a66c4 100644
--- a/net/dgd-lpmud/Makefile
+++ b/net/dgd-lpmud/Makefile
@@ -61,9 +61,6 @@ post-install:
${MKDIR} ${DATADIR}/tmp
# Link in the dgd docs
${LN} -sf ${PREFIX}/share/doc/dgd/kfun ${DATADIR}/lpmud/doc
- # Run package install script
- ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGDIR}/pkg-install ${PKGNAME} \
- POST-INSTALL
# Set mudlib ownership
-@${CHOWN} -h -R mud:mud ${DATADIR}
diff --git a/net/dgd-lpmud/pkg-deinstall b/net/dgd-lpmud/pkg-deinstall
deleted file mode 100644
index db9dbdbdfe72..000000000000
--- a/net/dgd-lpmud/pkg-deinstall
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-#
-
-if [ "$2" != "POST-DEINSTALL" ]; then
- exit 0
-fi
-
-USER=mud
-
-if pw usershow "${USER}" 2>/dev/null 1>&2; then
- echo "To delete MUD user permanently, use 'pw userdel \"${USER}\"'"
-fi
-
-exit 0
diff --git a/net/dgd-lpmud/pkg-install b/net/dgd-lpmud/pkg-install
deleted file mode 100644
index 575cbe714897..000000000000
--- a/net/dgd-lpmud/pkg-install
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-
-if [ "$2" = "PRE-INSTALL" ]; then
- exit 0
-fi
-
-PATH=/bin:/sbin:/usr/bin:/usr/sbin
-
-USER=mud
-GROUP=${USER}
-UID=97
-GID=${UID}
-
-if pw groupshow "${GROUP}" 2>/dev/null; then
- echo "Using existing group \"${GROUP}\"."
-else
- if pw groupadd "${GROUP}" -g ${GID}; then
- echo "Added group \"${GROUP}\"."
- else
- echo "Adding group \"${GROUP}\" failed..."
- exit 1
- fi
-fi
-
-if pw usershow "${USER}" 2>/dev/null; then
- echo "Using existing user \"${USER}\"."
-else
- if pw useradd "${USER}" -u ${UID} -g "${GROUP}" -h - \
- -s "/bin/sh" -d "/nonexistent" -c "MUD Owner"
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
-fi