aboutsummaryrefslogtreecommitdiff
path: root/net/dhcpd-pools/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-01-26 15:08:09 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-01-26 15:08:09 +0000
commitde13cf5bad1f9c8a6b122b2e4b49e13ab463e92a (patch)
tree5a1ab02c42ef5168bfb9c16a7e64e9cbe219f6a5 /net/dhcpd-pools/Makefile
parentacaa871bee014c82b4eba7befcd2e7b9955e21d9 (diff)
downloadports-de13cf5bad1f9c8a6b122b2e4b49e13ab463e92a.tar.gz
ports-de13cf5bad1f9c8a6b122b2e4b49e13ab463e92a.zip
New port: net/dhcpd-pools
Counts the usage ratio of each IP range and shared network pool that ISC dhcpd is in control of. It also allows you to generate csv output files for use with monitoring software. WWW: http://dhcpd-pools.sourceforge.net/
Notes
Notes: svn path=/head/; revision=289851
Diffstat (limited to 'net/dhcpd-pools/Makefile')
-rw-r--r--net/dhcpd-pools/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/dhcpd-pools/Makefile b/net/dhcpd-pools/Makefile
new file mode 100644
index 000000000000..0f39cb8ce57d
--- /dev/null
+++ b/net/dhcpd-pools/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: dhcpd-pools
+# Date created: 26 January 2012
+# Whom: Ryan Steinmetz (zi@FreeBSD.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= dhcpd-pools
+PORTVERSION= 2.16
+CATEGORIES= net
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= A tool to analyze isc-dhcp pool usage based on leases
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-dhcpd-conf=${LOCALBASE}/etc/dhcpd.conf \
+ --with-dhcpd-leases=/var/db/dhcpd/dhcpd.leases
+
+PLIST_FILES= bin/dhcpd-pools
+PORTDATA= dhcpd-pools.cgi snmptest.pl
+
+MAN1= dhcpd-pools.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/features.h/d' ${WRKSRC}/src/getdata.c
+
+.include <bsd.port.mk>