aboutsummaryrefslogtreecommitdiff
path: root/net/dhcpdump/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-14 02:17:49 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-14 02:17:49 +0000
commit8e72b58f8548c843117296b7742c9bedb4caf056 (patch)
tree001c64b0b249f40795373d4746951bd61e1f0608 /net/dhcpdump/Makefile
parentc46d97e4c5312dbaaaf44d304d1a6efa0583c58e (diff)
downloadports-8e72b58f8548c843117296b7742c9bedb4caf056.tar.gz
ports-8e72b58f8548c843117296b7742c9bedb4caf056.zip
Add dhcpdump 1.0, a program to decode and diagnose sniffed
DHCP packets. PR: 25481 Submitted by: Edwin Groothuis (edwin@mavetju.org)
Notes
Notes: svn path=/head/; revision=39807
Diffstat (limited to 'net/dhcpdump/Makefile')
-rw-r--r--net/dhcpdump/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/dhcpdump/Makefile b/net/dhcpdump/Makefile
new file mode 100644
index 000000000000..c69db873be1e
--- /dev/null
+++ b/net/dhcpdump/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: dhcpdump
+# Date created: 1 March 2001
+# Whom: Edwin Groothuis (edwin@mavetju.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= dhcpdump
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.mavetju.org/download/
+
+MAINTAINER= edwin@mavetju.org
+
+MAN1= dhcpdump.1
+
+pre-build:
+ ${PERL} -pi -e "s@gcc@${CC}@g; \
+ s@-Wall -g@-Wall ${CFLAGS}@g; \
+ s@/usr/local@${PREFIX}@g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>