aboutsummaryrefslogtreecommitdiff
path: root/net/dimes/Makefile
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2006-06-12 23:38:58 +0000
committerHerve Quiroz <hq@FreeBSD.org>2006-06-12 23:38:58 +0000
commit77aca9f804c2ea97a9915cee8007a0e99c373907 (patch)
tree26d224d8b303426fcec8d5def4992b04163b80f3 /net/dimes/Makefile
parent630e38559430d890754a1c4d967a6dee8499ced5 (diff)
downloadports-77aca9f804c2ea97a9915cee8007a0e99c373907.tar.gz
ports-77aca9f804c2ea97a9915cee8007a0e99c373907.zip
DIMES is a distributed scientific research project, aimed to study the
structure and topology of the Internet, with the help of a volunteer community (similar in spirit to projects such as SETI@Home). WWW: http://netdimes.org PR: 96161 Submitted by: Stas Timokhin <stast@bsdportal.ru>
Notes
Notes: svn path=/head/; revision=165278
Diffstat (limited to 'net/dimes/Makefile')
-rw-r--r--net/dimes/Makefile82
1 files changed, 82 insertions, 0 deletions
diff --git a/net/dimes/Makefile b/net/dimes/Makefile
new file mode 100644
index 000000000000..cf1f8135b290
--- /dev/null
+++ b/net/dimes/Makefile
@@ -0,0 +1,82 @@
+# New ports collection makefile for: DIMES
+# Date created: 18 April 2006
+# Whom: stast
+#
+# $FreeBSD$
+#
+
+PORTNAME= DIMES
+DISTVERSION= 0-4-2
+CATEGORIES= net java
+MASTER_SITES= http://netdimes.org/downloads/
+
+MAINTAINER= stast@bsdportal.ru
+COMMENT= Distributed research project for measurement topology of the Internet
+
+NO_PACKAGE= There is the string in properties.xml which system-depends
+NO_BUILD= .jar files are ready for use.
+
+WRKSRC= ${WRKDIR}/DIMES
+
+USE_JAVA= YES
+JAVA_VERSION= 1.4+
+#java-linux required
+JAVA_OS= linux
+#all vendors except forbidden: ibm
+JAVA_VENDOR= sun blackdown
+DATADIR= ${JAVASHAREDIR}/dimes
+
+post-patch:
+ cd ${WRKSRC}; echo "JAVA_HOME=${JAVA_HOME}" >> ${WRKSRC}/colors.sh;
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}/Classes
+ @${MKDIR} ${DATADIR}/Classes/Base
+ @${MKDIR} -m 0777 ${DATADIR}/Classes/Base/History
+ @${MKDIR} -m 0777 ${DATADIR}/Classes/Base/Incoming
+ @${MKDIR} -m 0777 ${DATADIR}/Classes/Base/Incoming/Keepalive
+ @${MKDIR} -m 0777 ${DATADIR}/Classes/Base/Outgoing
+ @${MKDIR} -m 0777 ${DATADIR}/Classes/Base/Outgoing/log
+ @${MKDIR} -m 0777 ${DATADIR}/Classes/Base/Outgoing/results
+ @${MKDIR} ${DATADIR}/Classes/Base/conf
+ @${MKDIR} ${DATADIR}/Classes/Base/resources
+ @${MKDIR} ${DATADIR}/Classes/Base
+ @${MKDIR} ${DATADIR}/Classes/Base
+ @${MKDIR} ${DATADIR}/Classes/JARs
+ @${MKDIR} ${DATADIR}/Licences
+ @${INSTALL_DATA} ${WRKSRC}/Classes/'AgentLauncher$$1.class' \
+ ${DATADIR}/Classes/'AgentLauncher$$1.class'
+ @${INSTALL_DATA} ${WRKSRC}/Classes/'AgentLauncher$$2.class' \
+ ${DATADIR}/Classes/'AgentLauncher$$2.class'
+ @${INSTALL_DATA} ${WRKSRC}/Classes/AgentLauncher.class \
+ ${DATADIR}/Classes/AgentLauncher.class
+ @cd ${WRKSRC}/Classes/ && \
+ ${FIND} . -type f -and \( -name "*.jpg" -or -name "*.gif" \
+ -or -name "*.dll" -or -name "*.ico" -or -name "*.so" \
+ -or -name "*.zip" -or -name "*.GIF" -or -name "*.txt" \
+ -or -name "*.properties" \) \
+ -exec ${INSTALL_DATA} {} ${DATADIR}/Classes/{} \;
+ @cd ${WRKSRC}/Classes/Base/resources/ && \
+ ${FIND} . -type f -and \( -name "*.jar" -or -name "*.txt" \
+ -or -name "*.keystore" \) \
+ -exec ${INSTALL_DATA} {} ${DATADIR}/Classes/Base/resources/{} \;
+ @${INSTALL_DATA} -m 0666 ${WRKSRC}/Classes/Base/resources/layouts.bin \
+ ${DATADIR}/Classes/Base/resources/layouts.bin
+ @${INSTALL_DATA} -m 0666 ${WRKSRC}/Classes/Base/resources/layouts.meta \
+ ${DATADIR}/Classes/Base/resources/layouts.meta
+ @${INSTALL_DATA} -m 0666 ${WRKSRC}/Classes/Base/conf/properties.xml \
+ ${DATADIR}/Classes/Base/conf/properties.xml
+ @${INSTALL_PROGRAM} ${WRKSRC}/Classes/JARs/jarsigner \
+ ${DATADIR}/Classes/JARs/jarsigner
+ @${INSTALL_DATA} ${WRKSRC}/Classes/JARs/10.jar \
+ ${DATADIR}/Classes/JARs/10.jar
+ @${INSTALL_DATA} ${WRKSRC}/Classes/JARs/dimesAgent.keystore \
+ ${DATADIR}/Classes/JARs/dimesAgent.keystore
+ @cd ${WRKSRC}/Licences/ && ${FIND} . -type f -name "*.txt" \
+ -exec ${INSTALL_MAN} {} ${DATADIR}/Licences/{} \;
+ @${INSTALL_SCRIPT} -m 4755 ${WRKSRC}/agent.sh ${DATADIR}/agent.sh
+ @${INSTALL_SCRIPT} ${WRKSRC}/colors.sh ${DATADIR}/colors.sh
+ cd ${WRKSRC}; ${SH} ./fix_permissions.sh; ./configure ${JAVASHAREDIR}
+
+.include <bsd.port.mk>