aboutsummaryrefslogtreecommitdiff
path: root/net/etherboot
diff options
context:
space:
mode:
authorEric L. Hernes <erich@FreeBSD.org>1999-04-18 13:43:02 +0000
committerEric L. Hernes <erich@FreeBSD.org>1999-04-18 13:43:02 +0000
commit0dc03b5b3344096b04b891d4607ce8bd3a8ef7e2 (patch)
treed551d8d2fc4f9de9d141bf81e8a7542963ca2171 /net/etherboot
parent523157e0cfaad89c3ac38a491c7543b221afd716 (diff)
downloadports-0dc03b5b3344096b04b891d4607ce8bd3a8ef7e2.tar.gz
ports-0dc03b5b3344096b04b891d4607ce8bd3a8ef7e2.zip
make it a bit more aesthetically pleasing.
Requested by: Satoshi, of course
Notes
Notes: svn path=/head/; revision=17970
Diffstat (limited to 'net/etherboot')
-rw-r--r--net/etherboot/Makefile13
-rw-r--r--net/etherboot/pkg-comment3
-rw-r--r--net/etherboot/pkg-descr39
3 files changed, 12 insertions, 43 deletions
diff --git a/net/etherboot/Makefile b/net/etherboot/Makefile
index e8dddd286ecc..3d73d10d14f1 100644
--- a/net/etherboot/Makefile
+++ b/net/etherboot/Makefile
@@ -1,16 +1,23 @@
+# New ports collection makefile for: etherboot
+# Version required: 4.1
+# Date created: 16 April 1999
+# Whom: Doug Ambrisko <ambrisko@whistle.com>
+#
+# $Id$
+#
DISTNAME= etherboot-4.1
-PKGNAME= etherboot-4.1
CATEGORIES= net
-DISTFILES= etherboot-4.1pre9.tar.bz2
MASTER_SITES= http://www.slug.org.au/etherboot/
+#DISTFILES= etherboot-4.1pre9.tar.bz2
+EXTRACT_SUFX= pre9.tar.bz2
MAINTAINER= ambrisko@whistle.com
BUILD_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2 \
${PREFIX}/bin/as86:${PORTSDIR}/devel/bcc
-EXTRACT_CMD= bzip2 -d <
+EXTRACT_CMD= bzip2 -d <
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= | tar xf -
diff --git a/net/etherboot/pkg-comment b/net/etherboot/pkg-comment
index 929557386106..c6f551797865 100644
--- a/net/etherboot/pkg-comment
+++ b/net/etherboot/pkg-comment
@@ -1,2 +1 @@
-Netboot FreeBSD a.out or ELF kernels. Has menu support and several device
-drivers.
+Netboot FreeBSD a.out/ELF kernels.
diff --git a/net/etherboot/pkg-descr b/net/etherboot/pkg-descr
index e313d5752cd8..51c8e1d50155 100644
--- a/net/etherboot/pkg-descr
+++ b/net/etherboot/pkg-descr
@@ -1,46 +1,9 @@
This code was originaly from FreeBSD and then the Linux folks greatly
enhanced its functionality and capabilities. It tftp's the kernel
-and boots it. It also has a menu capability. The only bad part is
-that it needs to be built in an Linux environment and needs my patch
-to linux_devel to run "brandelf" on static executables. Without this
-patch the intermediate static files will not run.
+and boots it. It also has a menu capability.
.rom & .com images are built in work/etherboot/src-32. Edit "Config"
in that directory for more features.
Note this is a memory corruption issue when I pre-populate the bootinfo
structure I need to look at it more.
-
-Here is a sample dhcpd.conf entry for isc-dhcp.
-
-server-identifier 192.168.1.31;
-
-group {
- subnet 192.168.1.0 netmask 255.255.255.0 {
- range dynamic-bootp 192.168.1.10 192.168.1.19;
- dynamic-bootp-lease-length 3600;
- option subnet-mask 255.255.255.0;
- option broadcast-address 192.168.1.255;
- option routers 192.168.1.30;
- option root-path "/crab/home1/usr/upgrade";
-
-
- host current3 {
- hardware ethernet 0:a0:c9:c7:e1:6f;
- fixed-address 192.168.1.25;
- option subnet-mask 255.255.255.0;
- option broadcast-address 192.168.1.255;
- option routers 192.168.1.30;
- option root-path "192.168.1.31:/crab/home1/usr/current";
- option option-128 "192.168.1.31:/crab/home1/usr/current";
-# option option-132 00:00:90:40;
- option option-132 00:00:90:00; # howto boot flags
- option option-176 3;
- option option-160 "timeout=30:default=206:";
- option option-192 "BSD:::/tftpboot/kernel";
- option option-193 "Load:::/tftpboot/kernel.load";
- option option-195 "MiniDOS:::/tftpboot/pcdr";
- option option-206 "ELF:::tftpboot/kernel.elf";
- }
- }
-}