aboutsummaryrefslogtreecommitdiff
path: root/net/etherboot
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-29 03:18:41 +0000
committerSteve Price <steve@FreeBSD.org>2000-05-29 03:18:41 +0000
commit6df78d2b8fd6b75d33c8b277e37bdc7dad7a8437 (patch)
tree8cec6a2abd5cf93bfdfd900b286eca40e7c6d0cf /net/etherboot
parent4116b82a4050c7faf4ace09d00f44e69215412d2 (diff)
downloadports-6df78d2b8fd6b75d33c8b277e37bdc7dad7a8437.tar.gz
ports-6df78d2b8fd6b75d33c8b277e37bdc7dad7a8437.zip
Update to version 4.6.1.
PR: 18626 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=28876
Diffstat (limited to 'net/etherboot')
-rw-r--r--net/etherboot/Makefile4
-rw-r--r--net/etherboot/distinfo2
-rw-r--r--net/etherboot/files/patch-aa45
-rw-r--r--net/etherboot/files/patch-ab27
4 files changed, 36 insertions, 42 deletions
diff --git a/net/etherboot/Makefile b/net/etherboot/Makefile
index 62823887c621..d3598f6611da 100644
--- a/net/etherboot/Makefile
+++ b/net/etherboot/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= etherboot
-PORTVERSION= 4.5.5
+PORTVERSION= 4.6.1
CATEGORIES= net
-MASTER_SITES= http://www.slug.org.au/etherboot/ \
+MASTER_SITES= http://etherboot.sourceforge.net/ \
http://www.us.kernel.org/pub/linux/devel/gcc/ \
http://www.ambrisko.com/doug/
DISTFILES= ${DISTNAME}.tar.gz ${BINUTILS_VER}.tar.gz
diff --git a/net/etherboot/distinfo b/net/etherboot/distinfo
index 35521126a047..461577ef00d7 100644
--- a/net/etherboot/distinfo
+++ b/net/etherboot/distinfo
@@ -1,2 +1,2 @@
-MD5 (etherboot-4.5.5.tar.gz) = 0c790b9158d33f03aceb299369bd046e
+MD5 (etherboot-4.6.1.tar.gz) = 2d450c003c5f3e5de936ded468fd2e5a
MD5 (binutils-2.9.1.0.25.tar.gz) = 2350a282f8fd53b409f523e77fccb904
diff --git a/net/etherboot/files/patch-aa b/net/etherboot/files/patch-aa
index 25c84b73596c..0d35ff11ff50 100644
--- a/net/etherboot/files/patch-aa
+++ b/net/etherboot/files/patch-aa
@@ -30,31 +30,20 @@
# if your as has trouble with the data32 directive, uncomment this
# but note that the premade start*.o will be larger than necessary because it
***************
-*** 166,171 ****
---- 169,175 ----
- PRLOADER= bin/prloader.bin
- RZLOADER= bin/rzloader.bin
- PRZLOADER= bin/przloader.bin
-+ FLOPPYLOAD= floppyload.bin.pre
- COMLOAD= bin/comload.bin
- endif
-
-*** Config.orig Sat Mar 18 00:27:39 2000
---- Config Mon Mar 20 11:15:44 2000
-***************
-*** 114,120 ****
- CFLAGS32+= -DPASSWD -DUSRPARMS -DFLOPPY
-
- # For a serial console, which can run in parallel with CRT console
-! CFLAGS32+= -DCONSOLE_DUAL -DCOMCONSOLE=0x3f8 -DCONSPEED=57600
-
- # Enable generic ELF, Multiboot ELF or FreeBSD ELF/a.out boot image support
- CFLAGS32+= -DELF_IMAGE -DAOUT_IMAGE -DIMAGE_MULTIBOOT -DIMAGE_FREEBSD
---- 114,120 ----
- CFLAGS32+= -DPASSWD -DUSRPARMS -DFLOPPY
-
- # For a serial console, which can run in parallel with CRT console
-! #CFLAGS32+= -DCONSOLE_DUAL -DCOMCONSOLE=0x3f8 -DCONSPEED=9600
-
- # Enable generic ELF, Multiboot ELF or FreeBSD ELF/a.out boot image support
- CFLAGS32+= -DELF_IMAGE -DAOUT_IMAGE -DIMAGE_MULTIBOOT -DIMAGE_FREEBSD
+*** 207,213 ****
+ || { $(RM) $@; echo "ERROR: code size exceeds limit!"; exit 1; }
+
+ # Make sure that the relocation address is acceptable for all ROM sizes
+! RELOCADDR=0x98000
+ # Evaluate ROMLIMIT only once - it is constant during the make run.
+ # Note that the 3K safety margin below is for the 1K extended BIOS data area
+ # and for the Etherboot runtime stack. Under normal situations, 2K of stack
+--- 211,218 ----
+ || { $(RM) $@; echo "ERROR: code size exceeds limit!"; exit 1; }
+
+ # Make sure that the relocation address is acceptable for all ROM sizes
+! #RELOCADDR=0x98000
+! RELOCADDR=0x8f000
+ # Evaluate ROMLIMIT only once - it is constant during the make run.
+ # Note that the 3K safety margin below is for the 1K extended BIOS data area
+ # and for the Etherboot runtime stack. Under normal situations, 2K of stack
diff --git a/net/etherboot/files/patch-ab b/net/etherboot/files/patch-ab
index 78d06d38afac..328288314780 100644
--- a/net/etherboot/files/patch-ab
+++ b/net/etherboot/files/patch-ab
@@ -1,14 +1,19 @@
-*** linux-asm-string.h.orig Sat Mar 18 20:15:54 2000
---- linux-asm-string.h Sat Mar 18 20:40:49 2000
+*** Config.orig Mon May 15 10:15:18 2000
+--- Config Mon May 15 10:16:04 2000
***************
-*** 19,27 ****
- * consider these trivial functions to be PD.
- */
+*** 143,149 ****
+ # CFLAGS32+= -DCONSOLE_DUAL -DCOMCONSOLE=0x3f8 -DCONSPEED=9600
-- #ifndef __FreeBSD__
- typedef int size_t;
-- #endif
+ # Enable generic ELF, Multiboot ELF or FreeBSD ELF/a.out boot image support
+! # CFLAGS32+= -DELF_IMAGE -DAOUT_IMAGE -DIMAGE_MULTIBOOT -DIMAGE_FREEBSD
- extern void *__memcpy(void * to, const void * from, size_t n);
- extern void *__constant_memcpy(void * to, const void * from, size_t n);
---- 19,25 ----
+ # Change download protocol to NFS. Only available for Etherboot/32 for now.
+ # CFLAGS32+= -DDOWNLOAD_PROTO_NFS
+--- 143,149 ----
+ # CFLAGS32+= -DCONSOLE_DUAL -DCOMCONSOLE=0x3f8 -DCONSPEED=9600
+
+ # Enable generic ELF, Multiboot ELF or FreeBSD ELF/a.out boot image support
+! CFLAGS32+= -DELF_IMAGE -DAOUT_IMAGE -DIMAGE_MULTIBOOT -DIMAGE_FREEBSD
+
+ # Change download protocol to NFS. Only available for Etherboot/32 for now.
+ # CFLAGS32+= -DDOWNLOAD_PROTO_NFS