aboutsummaryrefslogtreecommitdiff
path: root/net/exabgp4
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2021-11-11 12:54:05 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2021-11-11 12:54:05 +0000
commit33a0add7bd9234cd8879aeb7811f5c0987055022 (patch)
treed80685fe96e111c970368f12e16bd560cc8cd19a /net/exabgp4
parentc4b5604d1976dd4cb2c0e6c25e32071698abb31e (diff)
downloadports-33a0add7bd9234cd8879aeb7811f5c0987055022.tar.gz
ports-33a0add7bd9234cd8879aeb7811f5c0987055022.zip
net/exabgp4: Bring back socket loop fix, bump PORTREVISION
Diffstat (limited to 'net/exabgp4')
-rw-r--r--net/exabgp4/Makefile2
-rw-r--r--net/exabgp4/files/patch-lib_exabgp_reactor_network_outgoing.py11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/exabgp4/Makefile b/net/exabgp4/Makefile
index f7cbe6df635d..36062d447510 100644
--- a/net/exabgp4/Makefile
+++ b/net/exabgp4/Makefile
@@ -2,7 +2,7 @@
PORTNAME= exabgp
PORTVERSION= 4.2.13
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= GH \
ZI
diff --git a/net/exabgp4/files/patch-lib_exabgp_reactor_network_outgoing.py b/net/exabgp4/files/patch-lib_exabgp_reactor_network_outgoing.py
new file mode 100644
index 000000000000..2bc959c98d78
--- /dev/null
+++ b/net/exabgp4/files/patch-lib_exabgp_reactor_network_outgoing.py
@@ -0,0 +1,11 @@
+--- lib/exabgp/reactor/network/outgoing.py.orig 2021-03-19 09:29:00 UTC
++++ lib/exabgp/reactor/network/outgoing.py
+@@ -53,6 +53,8 @@ class Outgoing(Connection):
+ connect(self.io, self.peer, self.port, self.afi, self.md5)
+ return None
+ except Exception as exc:
++ self.io.close()
++ self.io = None
+ return exc
+
+ def establish(self):