aboutsummaryrefslogtreecommitdiff
path: root/net/fping/Makefile
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-04-22 15:44:41 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-04-22 15:44:41 +0000
commit6abb3ce3f8d79a09f9ce6034cf2ec650b193970c (patch)
tree106d95f0dc7a17e93d968574016d2bf3b5628723 /net/fping/Makefile
parent0ef2b592d1b65fc4aac1f1764f5c813051202fb1 (diff)
downloadports-6abb3ce3f8d79a09f9ce6034cf2ec650b193970c.tar.gz
ports-6abb3ce3f8d79a09f9ce6034cf2ec650b193970c.zip
- Add timestamps option (used by netperf-wrapper) [1]
- Fix fping issue with the unreachable ip in the arp cache [2] - Convert Makefile headers to new style PR: ports/177368 [1] PR: ports/176439 [2] Submitted by: Lars Eggert <lars@eggert.org> [1], Alexandre RAYNAUD <alexandre.raynaud@sallanches.fr> [2] Approved by: Jason Harris <jharris@widomaker.com> (maintainer)
Notes
Notes: svn path=/head/; revision=316242
Diffstat (limited to 'net/fping/Makefile')
-rw-r--r--net/fping/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/net/fping/Makefile b/net/fping/Makefile
index 0064e925ff80..89dcf003f04a 100644
--- a/net/fping/Makefile
+++ b/net/fping/Makefile
@@ -1,22 +1,23 @@
-# ex:ts=8
-# Ports collection makefile for: fping
-# Date created: Tue Mar 25, 1997
-# Whom: David O'Brien (obrien@NUXI.com)
-#
+# Created by: David O'Brien (obrien@NUXI.com)
# $FreeBSD$
-#
PORTNAME= fping
PORTVERSION= 3.4
+PORTREVISION= 1
CATEGORIES= net ipv6
-MASTER_SITES= http://fping.org/dist/
+MASTER_SITES= http://fping.org/dist/
+
+PATCH_SITES= https://raw.github.com/tohojo/netperf-wrapper/master/misc/
+PATCH_DIST_STRIP= -p1
MAINTAINER= jharris@widomaker.com
COMMENT= Quickly ping N hosts w/o flooding the network
+OPTIONS_DEFINE= TIMESTAMPS
OPTIONS_MULTI= NET
OPTIONS_MULTI_NET= IPV4 IPV6
OPTIONS_DEFAULT= IPV4
+TIMESTAMPS_DESC= Enable timestamps
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --bindir="${PREFIX}/sbin"
@@ -39,6 +40,10 @@ MAN8+= fping6.8
CONFIGURE_ARGS+=--disable-ipv6
.endif
+.if ${PORT_OPTIONS:MTIMESTAMPS}
+PATCHFILES+= fping_timestamps.patch
+.endif
+
post-install:
.if ${PORT_OPTIONS:MIPV4}
@${STRIP_CMD} ${PREFIX}/sbin/fping