aboutsummaryrefslogtreecommitdiff
path: root/net/freenet6
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-20 20:45:55 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-20 20:45:55 +0000
commit23036526db217ed9c7dc03ea6f88ba29b34a4062 (patch)
treed1e067e03b885fffb796683762875af3822123b1 /net/freenet6
parente0c0d00cc2e522c364d78b09e76788427af18745 (diff)
downloadports-23036526db217ed9c7dc03ea6f88ba29b34a4062.tar.gz
ports-23036526db217ed9c7dc03ea6f88ba29b34a4062.zip
- don't try to modify things outside of ${WRKDIR}
- cleanup pkg-message handling: we don't need a base pkg-message: we generate ${WRKSRC}/pkg-message from ${FILESDIR}/pkg-message.in - pkg-message -> ${PKGMESSAGE} - use a different example host to ping6 in pkg-message.in PR: 31921 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=50284
Diffstat (limited to 'net/freenet6')
-rw-r--r--net/freenet6/Makefile13
-rw-r--r--net/freenet6/files/pkg-message.in2
-rw-r--r--net/freenet6/pkg-message7
3 files changed, 7 insertions, 15 deletions
diff --git a/net/freenet6/Makefile b/net/freenet6/Makefile
index 9602433bebad..53d18a168c55 100644
--- a/net/freenet6/Makefile
+++ b/net/freenet6/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= edwin@mavetju.org
MAN8= tspc.8
MAN5= tspc.conf.5
+PKGMESSAGE= ${WRKSRC}/pkg-message
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400000
@@ -50,17 +52,17 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/template/freebsd4.sh ${PREFIX}/bin/tspc-freebsd4.sh
@${INSTALL_MAN} ${WRKSRC}/man/man8/tspc.8 ${PREFIX}/man/man8
@${INSTALL_MAN} ${WRKSRC}/man/man5/tspc.conf.5 ${PREFIX}/man/man5
- @${INSTALL_SCRIPT} ${FILESDIR}/freenet6.sh ${PREFIX}/etc/rc.d/
+ @${INSTALL_SCRIPT} ${WRKSRC}/freenet6.sh ${PREFIX}/etc/rc.d/
post-install:
- @${CAT} pkg-message
+ @${CAT} ${PKGMESSAGE}
post-patch:
@${MV} ${WRKSRC}/src/tspc.c ${WRKSRC}/src/tspc.c.orig
@${SED} -e "s|tspc.conf|${PREFIX}/etc/tspc.conf|" < ${WRKSRC}/src/tspc.c.orig > ${WRKSRC}/src/tspc.c
- @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/freenet6.sh.in > ${FILESDIR}/freenet6.sh
- @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/pkg-message.in > pkg-message
+ @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/freenet6.sh.in > ${WRKSRC}/freenet6.sh
+ @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/pkg-message.in > ${WRKSRC}/pkg-message
@${MV} ${WRKSRC}/man/man8/tspc.8 ${WRKSRC}/man/man8/tspc.8.orig
@${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${WRKSRC}/man/man8/tspc.8.orig > ${WRKSRC}/man/man8/tspc.8
@@ -68,7 +70,4 @@ post-patch:
@${MV} ${WRKSRC}/man/man5/tspc.conf.5 ${WRKSRC}/man/man5/tspc.conf.5.orig
@${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${WRKSRC}/man/man5/tspc.conf.5.orig > ${WRKSRC}/man/man5/tspc.conf.5
-post-clean:
- @${RM} -f ${FILESDIR}/freenet6.sh
-
.include <bsd.port.post.mk>
diff --git a/net/freenet6/files/pkg-message.in b/net/freenet6/files/pkg-message.in
index ef3f3edf5dcc..df4cb21810a3 100644
--- a/net/freenet6/files/pkg-message.in
+++ b/net/freenet6/files/pkg-message.in
@@ -4,4 +4,4 @@ Now that the package is installed, please finish it with the following steps:
- Check the values of @@PREFIX@@/etc/tspc.conf. If you have registered at
the website, fill in your userid and password there.
- Run @@PREFIX@@/etc/rc.d/freenet6.sh to start the tunnel.
-- Try to ping a IPv6 host, for example: ping6 mud6.fataldimensions.org
+- Try to ping a IPv6 host, for example: ping6 www.jp.freebsd.org
diff --git a/net/freenet6/pkg-message b/net/freenet6/pkg-message
deleted file mode 100644
index 78c5ae4a3a39..000000000000
--- a/net/freenet6/pkg-message
+++ /dev/null
@@ -1,7 +0,0 @@
-Now that the package is installed, please finish it with the following steps:
-
-- Copy /usr/local/etc/tspc.conf.sample to /usr/local/etc/tspc.conf
-- Check the values of /usr/local/etc/tspc.conf. If you have registered at
- the website, fill in your userid and password there.
-- Run /usr/local/etc/rc.d/freenet6.sh to start the tunnel.
-- Try to ping a IPv6 host, for example: ping6 mud6.fataldimensions.org