aboutsummaryrefslogtreecommitdiff
path: root/net/freenet6
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-11-08 15:24:26 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-11-08 15:24:26 +0000
commit9cadab2a15c4ebdc7ddebe0f965348b4d6daddec (patch)
tree11ba87fb75e0c9dd032b8f637e75705617763470 /net/freenet6
parent90363bb3925a4dddf84ac41d45a1e0214e760f4e (diff)
downloadports-9cadab2a15c4ebdc7ddebe0f965348b4d6daddec.tar.gz
ports-9cadab2a15c4ebdc7ddebe0f965348b4d6daddec.zip
Initial import of freenet6-0.9.5.
Freenet is the Freenet6 Tunnel Setup Protocol Client PR: 31791 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Notes
Notes: svn path=/head/; revision=49844
Diffstat (limited to 'net/freenet6')
-rw-r--r--net/freenet6/Makefile74
-rw-r--r--net/freenet6/distinfo1
-rw-r--r--net/freenet6/files/freenet6.sh.in30
-rw-r--r--net/freenet6/files/patch-man-man5-tspc.conf.511
-rw-r--r--net/freenet6/files/patch-man-man8-tspc.811
-rw-r--r--net/freenet6/files/patch-src-Makefile11
-rw-r--r--net/freenet6/files/patch-src-tspc.c21
-rw-r--r--net/freenet6/files/patch-template-freebsd4.sh12
-rw-r--r--net/freenet6/files/patch-template-freebsd44.sh12
-rw-r--r--net/freenet6/files/pkg-message.in7
-rw-r--r--net/freenet6/pkg-comment1
-rw-r--r--net/freenet6/pkg-descr31
-rw-r--r--net/freenet6/pkg-message7
-rw-r--r--net/freenet6/pkg-plist6
14 files changed, 235 insertions, 0 deletions
diff --git a/net/freenet6/Makefile b/net/freenet6/Makefile
new file mode 100644
index 000000000000..9602433bebad
--- /dev/null
+++ b/net/freenet6/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: freenet6
+# Date created: 11 Oct 2001
+# Whom: Edwin Groothuis (edwin@mavetju.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= freenet6
+PORTVERSION= 0.9.5
+CATEGORIES= net ipv6
+MASTER_SITES= # fetch manually
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= edwin@mavetju.org
+
+MAN8= tspc.8
+MAN5= tspc.conf.5
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400000
+IGNORE= This program might not be working on FreeBSD version below 4.0
+.endif
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= May not be automatically fetched due to licensing\
+ restrictions. You MUST manually fetch the version\
+ after reading and agreeing to the license at:\
+ http://www.freenet6.net/cgi-bin/download.cgi?fn=${DISTFILES} \
+ Once it has been downloaded, move it to\
+ ${DISTDIR} and then restart this build.\
+ You also can register to use this service at\
+ http://www.freenet6.net/cgi-bin/new_account.pl
+.endif
+
+NO_CDROM= "Redistribution not allowed"
+NO_PACKAGE= "Redistribution not allowed"
+
+.if ${OSVERSION} >= 440000
+MAKE_ARGS= target=freebsd44 installdir=${PREFIX}
+.else
+MAKE_ARGS= target=freebsd4 installdir=${PREFIX}
+.endif
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/bin/tspc ${PREFIX}/bin/tspc
+ @${INSTALL_DATA} ${WRKSRC}/bin/tspc.conf ${PREFIX}/etc/tspc.conf.sample
+ @${INSTALL_SCRIPT} ${WRKSRC}/template/checktunnel.sh ${PREFIX}/bin/checktunnel.sh
+ @${INSTALL_SCRIPT} ${WRKSRC}/template/freebsd44.sh ${PREFIX}/bin/tspc-freebsd44.sh
+ @${INSTALL_SCRIPT} ${WRKSRC}/template/freebsd4.sh ${PREFIX}/bin/tspc-freebsd4.sh
+ @${INSTALL_MAN} ${WRKSRC}/man/man8/tspc.8 ${PREFIX}/man/man8
+ @${INSTALL_MAN} ${WRKSRC}/man/man5/tspc.conf.5 ${PREFIX}/man/man5
+ @${INSTALL_SCRIPT} ${FILESDIR}/freenet6.sh ${PREFIX}/etc/rc.d/
+
+post-install:
+ @${CAT} pkg-message
+
+post-patch:
+ @${MV} ${WRKSRC}/src/tspc.c ${WRKSRC}/src/tspc.c.orig
+ @${SED} -e "s|tspc.conf|${PREFIX}/etc/tspc.conf|" < ${WRKSRC}/src/tspc.c.orig > ${WRKSRC}/src/tspc.c
+
+ @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/freenet6.sh.in > ${FILESDIR}/freenet6.sh
+ @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${FILESDIR}/pkg-message.in > pkg-message
+
+ @${MV} ${WRKSRC}/man/man8/tspc.8 ${WRKSRC}/man/man8/tspc.8.orig
+ @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${WRKSRC}/man/man8/tspc.8.orig > ${WRKSRC}/man/man8/tspc.8
+
+ @${MV} ${WRKSRC}/man/man5/tspc.conf.5 ${WRKSRC}/man/man5/tspc.conf.5.orig
+ @${SED} -e "s|@@PREFIX@@|${PREFIX}|g" < ${WRKSRC}/man/man5/tspc.conf.5.orig > ${WRKSRC}/man/man5/tspc.conf.5
+
+post-clean:
+ @${RM} -f ${FILESDIR}/freenet6.sh
+
+.include <bsd.port.post.mk>
diff --git a/net/freenet6/distinfo b/net/freenet6/distinfo
new file mode 100644
index 000000000000..dd30d722607c
--- /dev/null
+++ b/net/freenet6/distinfo
@@ -0,0 +1 @@
+MD5 (freenet6-0.9.5.tgz) = 31f4a7babeb7523bf182c87f498aa06c
diff --git a/net/freenet6/files/freenet6.sh.in b/net/freenet6/files/freenet6.sh.in
new file mode 100644
index 000000000000..cc23ffa382a4
--- /dev/null
+++ b/net/freenet6/files/freenet6.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Start or stop the IPv6 tunnel to Freenet6.net
+#
+
+case "$1" in
+ start)
+ echo -n " freenet6"
+ if [ -f @@PREFIX@@/etc/tspc.conf ]; then
+ @@PREFIX@@/bin/tspc
+ fi
+ ;;
+
+ stop)
+ if [ ! -f /var/run/tspc.if ]; then
+ echo "TSPC not running"
+ exit 64
+ fi
+ /sbin/ifconfig `cat /var/run/tspc.if` destroy
+ ;;
+
+ *)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ exit 64
+ ;;
+esac
diff --git a/net/freenet6/files/patch-man-man5-tspc.conf.5 b/net/freenet6/files/patch-man-man5-tspc.conf.5
new file mode 100644
index 000000000000..25bee6d8575b
--- /dev/null
+++ b/net/freenet6/files/patch-man-man5-tspc.conf.5
@@ -0,0 +1,11 @@
+--- man/man5/tspc.conf.5.orig Thu Oct 11 16:10:36 2001
++++ man/man5/tspc.conf.5 Thu Oct 11 16:09:07 2001
+@@ -96,7 +96,7 @@
+ The current directory where tspc programs and templates are located. This
+ variable might look something like this:
+ .Pp
+-tsp_dir=/usr/local/tsp
++tsp_dir=@@PREFIX@@
+ .Pp
+ This variable is MANDATORY.
+ .It Sy client_v4
diff --git a/net/freenet6/files/patch-man-man8-tspc.8 b/net/freenet6/files/patch-man-man8-tspc.8
new file mode 100644
index 000000000000..781fc9263994
--- /dev/null
+++ b/net/freenet6/files/patch-man-man8-tspc.8
@@ -0,0 +1,11 @@
+--- man/man8/tspc.8.orig Thu Oct 11 16:07:07 2001
++++ man/man8/tspc.8 Thu Oct 11 16:07:22 2001
+@@ -85,7 +85,7 @@
+ .Pp
+ .It Fl f Ar configuration_file
+ Specifies a different configuration file to be used in placed of
+-the default file /usr/local/tsp/etc/tspc.conf. The file format is
++the default file @@PREFIX@@/etc/tspc.conf. The file format is
+ detailed in
+ .Xr tspc.conf 5
+ and lists the options available to customize the client.
diff --git a/net/freenet6/files/patch-src-Makefile b/net/freenet6/files/patch-src-Makefile
new file mode 100644
index 000000000000..87461ceb47d1
--- /dev/null
+++ b/net/freenet6/files/patch-src-Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile.orig Sat Sep 8 01:52:26 2001
++++ src/Makefile Thu Oct 11 13:01:53 2001
+@@ -22,7 +22,7 @@
+ @echo Installing tspc
+ mkdir -p $(install_bin)
+ $(COPY) $(BIN)/$(TSPC) $(install_bin)/$(TSPC)
+- $(COPY) $(BIN)/tspc.conf $(install_bin)/tspc.conf
++ $(COPY) $(BIN)/tspc.conf $(install_etc)/tspc.conf
+ @echo End of tspc installation
+
+ $(BIN)/tspc.conf:
diff --git a/net/freenet6/files/patch-src-tspc.c b/net/freenet6/files/patch-src-tspc.c
new file mode 100644
index 000000000000..6abc77ce6752
--- /dev/null
+++ b/net/freenet6/files/patch-src-tspc.c
@@ -0,0 +1,21 @@
+--- src/tspc.c.orig Tue Sep 11 23:41:05 2001
++++ src/tspc.c Thu Oct 11 13:27:31 2001
+@@ -178,7 +178,7 @@
+ int Initialise(int argc, char *argv[], tConf *Conf)
+ {
+ tConf CmdLine;
+- char *Templ = "template";
++ char *Templ = "bin";
+ extern int ReadConfigFile(char *File, tConf *Conf);
+
+ Conf->tsp_dir = NULL;
+@@ -554,7 +554,7 @@
+ SetEnv("TSP_VERBOSE", buf, 1);
+ SetEnv("TSP_HOME_DIR", TspHomeDir, 1);
+
+- snprintf(buf, sizeof buf, "%s%s%c%s.%s", ScriptInterpretor, ScriptDir, DirSeparator, Conf.template, ScriptExtension);
++ snprintf(buf, sizeof buf, "%s%s%ctspc-%s.%s", ScriptInterpretor, ScriptDir, DirSeparator, Conf.template, ScriptExtension);
+
+ Display(2, ELInfo, "SetUpInterface", "Executing configuration script.\n");
+ Display(2, ELInfo, "SetUpInterface", buf);
+
diff --git a/net/freenet6/files/patch-template-freebsd4.sh b/net/freenet6/files/patch-template-freebsd4.sh
new file mode 100644
index 000000000000..daf81264e817
--- /dev/null
+++ b/net/freenet6/files/patch-template-freebsd4.sh
@@ -0,0 +1,12 @@
+--- template/freebsd4.sh.orig Thu Oct 11 16:40:29 2001
++++ template/freebsd4.sh Thu Oct 11 16:40:48 2001
+@@ -110,6 +110,9 @@
+ # Delete any default IPv6 route first
+ Exec $route delete -inet6 default
+ Exec $route add -inet6 default -interface $TSP_TUNNEL_INTERFACE
++
++ # Save interface for later
++ echo $TSP_TUNNEL_INTERFACE > /var/run/tspc.if
+ fi
+
+ # Router configuration if required
diff --git a/net/freenet6/files/patch-template-freebsd44.sh b/net/freenet6/files/patch-template-freebsd44.sh
new file mode 100644
index 000000000000..02929ccc7b34
--- /dev/null
+++ b/net/freenet6/files/patch-template-freebsd44.sh
@@ -0,0 +1,12 @@
+--- template/freebsd44.sh.orig Tue Aug 28 04:15:58 2001
++++ template/freebsd44.sh Thu Oct 11 15:22:00 2001
+@@ -106,6 +106,9 @@
+ # Delete any default IPv6 route first
+ Exec $route delete -inet6 default
+ Exec $route add -inet6 default -interface $TSP_TUNNEL_INTERFACE
++
++ # Save interface for later
++ echo $TSP_TUNNEL_INTERFACE > /var/run/tspc.if
+ fi
+
+ # Router configuration if required
diff --git a/net/freenet6/files/pkg-message.in b/net/freenet6/files/pkg-message.in
new file mode 100644
index 000000000000..ef3f3edf5dcc
--- /dev/null
+++ b/net/freenet6/files/pkg-message.in
@@ -0,0 +1,7 @@
+Now that the package is installed, please finish it with the following steps:
+
+- Copy @@PREFIX@@/etc/tspc.conf.sample to @@PREFIX@@/etc/tspc.conf
+- Check the values of @@PREFIX@@/etc/tspc.conf. If you have registered at
+ the website, fill in your userid and password there.
+- Run @@PREFIX@@/etc/rc.d/freenet6.sh to start the tunnel.
+- Try to ping a IPv6 host, for example: ping6 mud6.fataldimensions.org
diff --git a/net/freenet6/pkg-comment b/net/freenet6/pkg-comment
new file mode 100644
index 000000000000..612424b9263b
--- /dev/null
+++ b/net/freenet6/pkg-comment
@@ -0,0 +1 @@
+Freenet6 Tunnel Setup Protocol Client - Free IPv6 tunnel
diff --git a/net/freenet6/pkg-descr b/net/freenet6/pkg-descr
new file mode 100644
index 000000000000..820e4af904e3
--- /dev/null
+++ b/net/freenet6/pkg-descr
@@ -0,0 +1,31 @@
+Freenet6's TSP is a new initiative launched by Viagenie, a private
+company in Canada involved in IPv6 since 1996, to facilitate a
+faster deployment of an Internet IPv6. Internet is world-wide
+deployed over IPv4, therefore this project has the main goal of
+deploying IPv6 at a larger scale by using configured tunnels.
+
+Configured tunnel is a transitional method standardized by the IETF
+to use IPv6 in coexistence with IPv4 by encapsulating IPv6 packets
+over IPv4. Any host already connected to Internet with IPv4 and
+having an IPv6 stack could establish link to Internet IPv6.
+
+Freenet6, developed by Viagenie in 1999-2000, was the first public
+tunnel server service and one of the most used in the world to
+delegate automatically one single IPv6 address to any host already
+connected to an IPv4 network over configured tunnel simply by
+filling a Web form and running a script. Freenet6's TSP is representing
+another very important step to accelerate the deployment at large
+scale of IPv6 to everyone on the net.
+
+Instead of a Web interface to request configured tunnels and IPv6
+addresses, Freenet6's TSP is a new model based on a client/server
+approach. A protocol is used to request one single IPv6 address to
+a full IPv6 prefix from a client to a tunnel server according to
+the IPv6 broker model. The protocol could be integrated directly
+into the operating system to give a service like DHCP but for
+requesting IPv6 addresses or prefixes over an IPv4 network (Internet).
+
+WWW: http://www.freenet6.net
+
+- Edwin Groothuis
+edwin@mavetju.org
diff --git a/net/freenet6/pkg-message b/net/freenet6/pkg-message
new file mode 100644
index 000000000000..78c5ae4a3a39
--- /dev/null
+++ b/net/freenet6/pkg-message
@@ -0,0 +1,7 @@
+Now that the package is installed, please finish it with the following steps:
+
+- Copy /usr/local/etc/tspc.conf.sample to /usr/local/etc/tspc.conf
+- Check the values of /usr/local/etc/tspc.conf. If you have registered at
+ the website, fill in your userid and password there.
+- Run /usr/local/etc/rc.d/freenet6.sh to start the tunnel.
+- Try to ping a IPv6 host, for example: ping6 mud6.fataldimensions.org
diff --git a/net/freenet6/pkg-plist b/net/freenet6/pkg-plist
new file mode 100644
index 000000000000..ef39e79cb1c6
--- /dev/null
+++ b/net/freenet6/pkg-plist
@@ -0,0 +1,6 @@
+bin/tspc
+etc/tspc.conf.sample
+bin/tspc-freebsd4.sh
+bin/tspc-freebsd44.sh
+bin/checktunnel.sh
+etc/rc.d/freenet6.sh