aboutsummaryrefslogtreecommitdiff
path: root/net/gitlab-agent/Makefile
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-07-12 12:13:03 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-07-12 18:56:04 +0000
commit7d1faa7179813ffa542b550a1fdb3bdc80a7986c (patch)
treebca2e70f4a6137f858d0ca5792e376602af7bab7 /net/gitlab-agent/Makefile
parent16bde072b16daca1c886116e602c94b5fa99c20f (diff)
downloadports-7d1faa7179813ffa542b550a1fdb3bdc80a7986c.tar.gz
ports-7d1faa7179813ffa542b550a1fdb3bdc80a7986c.zip
bsd.sites.mk: Update all ports using USE_GITLAB
Replace GL_COMMIT by GL_TAGNAME in all ports. The new GL_TAGNAME is backwards-compatible (accepting any commit hash as before), but also understands an actual tag name. Moving to tag names where appropriate is left to individual ports' maintainers. Approved by: portmgr (tcberner, mentor) Differential Revision: https://reviews.freebsd.org/D37077
Diffstat (limited to 'net/gitlab-agent/Makefile')
-rw-r--r--net/gitlab-agent/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/gitlab-agent/Makefile b/net/gitlab-agent/Makefile
index 38ddeb8764c6..fbaa97eeff71 100644
--- a/net/gitlab-agent/Makefile
+++ b/net/gitlab-agent/Makefile
@@ -20,7 +20,7 @@ _BUILD_DATE= $$(date -u "+%Y-%m-%d-%H%M UTC")
GO_BUILDFLAGS= -tags="tracer_static,tracer_static_jaeger" \
-ldflags=" \
-X 'gitlab.com/gitlab-org/cluster-integration/gitlab-agent/v16/cmd.Version=v${PORTVERSION}' \
- -X 'gitlab.com/gitlab-org/cluster-integration/gitlab-agent/v16/cmd.Commit=${GL_COMMIT:C/^(........).*/\1/}' \
+ -X 'gitlab.com/gitlab-org/cluster-integration/gitlab-agent/v16/cmd.Commit=${GL_TAGNAME:C/^(........).*/\1/}' \
-X 'gitlab.com/gitlab-org/cluster-integration/gitlab-agent/v16/cmd.BuildTime=${_BUILD_DATE}'"
GO_TARGET= ./cmd/kas