aboutsummaryrefslogtreecommitdiff
path: root/net/gmid
diff options
context:
space:
mode:
authorOmar Polo <freebsd@omarpolo.com>2024-01-14 11:44:53 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-01-14 20:31:22 +0000
commit734004ab94697ff6ac7df3679d5f7bcf4b7784b8 (patch)
treeeecd245dadab3d3b1dc17a7b0f716b5094eacb11 /net/gmid
parent4591d6c1a6e6eea877edefd3dc325d3873379a2b (diff)
downloadports-734004ab94697ff6ac7df3679d5f7bcf4b7784b8.tar.gz
ports-734004ab94697ff6ac7df3679d5f7bcf4b7784b8.zip
net/gmid: Update to 2.0
* Add https://ftp.omarpolo.com/ to MASTER_SITES * Minor adjustments to Makefile * Strip binaries Changelog: https://github.com/omar-polo/gmid/releases/tag/2.0 PR: 276260
Diffstat (limited to 'net/gmid')
-rw-r--r--net/gmid/Makefile17
-rw-r--r--net/gmid/distinfo6
-rw-r--r--net/gmid/pkg-plist6
3 files changed, 18 insertions, 11 deletions
diff --git a/net/gmid/Makefile b/net/gmid/Makefile
index 0438ce9683b6..047a2d974341 100644
--- a/net/gmid/Makefile
+++ b/net/gmid/Makefile
@@ -1,8 +1,8 @@
PORTNAME= gmid
-DISTVERSION= 1.8.6
-PORTREVISION= 1
+DISTVERSION= 2.0
CATEGORIES= net
-MASTER_SITES= https://github.com/omar-polo/gmid/releases/download/${DISTVERSION}/
+MASTER_SITES= https://github.com/omar-polo/${PORTNAME}/releases/download/${DISTVERSION}/ \
+ https://ftp.omarpolo.com/
MAINTAINER= freebsd@omarpolo.com
COMMENT= Simple and secure Gemini server
@@ -11,8 +11,7 @@ WWW= https://gmid.omarpolo.com
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libevent.so:devel/libevent \
- libtls.so:security/libretls
+LIB_DEPENDS= libevent.so:devel/libevent
USES= localbase pkgconfig ssl
USE_RC_SUBR= gmid
@@ -21,13 +20,17 @@ HAS_CONFIGURE= yes
TEST_TARGET= regress
-LDFLAGS+= -lcrypto -lssl
-
USERS= _gmid
GROUPS= _gmid
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
+
post-install:
${INSTALL_DATA} ${FILESDIR}/gmid.conf.sample \
${STAGEDIR}${PREFIX}/etc/
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gemexp
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gg
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gmid
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/titan
.include <bsd.port.mk>
diff --git a/net/gmid/distinfo b/net/gmid/distinfo
index 157325ef8596..b2e6a36c737f 100644
--- a/net/gmid/distinfo
+++ b/net/gmid/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1669995538
-SHA256 (gmid-1.8.6.tar.gz) = 5e027012f50f56709a7f08a530fd0ecc90402142acdcd7cba6e23bd7a37d0bc8
-SIZE (gmid-1.8.6.tar.gz) = 121648
+TIMESTAMP = 1704989207
+SHA256 (gmid-2.0.tar.gz) = b6e0213eea014ce00326e9e0417150632e1988d79eab1d8d044c7dd3ea018f9d
+SIZE (gmid-2.0.tar.gz) = 182861
diff --git a/net/gmid/pkg-plist b/net/gmid/pkg-plist
index 29b7102e20e4..db4157f2d0cc 100644
--- a/net/gmid/pkg-plist
+++ b/net/gmid/pkg-plist
@@ -1,6 +1,10 @@
@sample etc/gmid.conf.sample
+bin/gemexp
bin/gg
bin/gmid
+bin/titan
+man/man1/gemexp.1.gz
man/man1/gg.1.gz
-man/man1/gmid.1.gz
+man/man1/titan.1.gz
man/man5/gmid.conf.5.gz
+man/man8/gmid.8.gz