aboutsummaryrefslogtreecommitdiff
path: root/net/gnome-netstatus
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-01-31 02:46:29 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-01-31 02:46:29 +0000
commitfe200ce608847779e1b1c99b8980458628cecdc1 (patch)
tree77ea2b96d18f092eef2233771ba6d398170bb11d /net/gnome-netstatus
parent89fc470ef1ab7061384098f779fcf82d79fed5ba (diff)
downloadports-fe200ce608847779e1b1c99b8980458628cecdc1.tar.gz
ports-fe200ce608847779e1b1c99b8980458628cecdc1.zip
Adjust the order of variable declarations to fix a problem getting the
signal strength from Aironet cards.
Notes
Notes: svn path=/head/; revision=154865
Diffstat (limited to 'net/gnome-netstatus')
-rw-r--r--net/gnome-netstatus/Makefile2
-rw-r--r--net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c18
2 files changed, 17 insertions, 3 deletions
diff --git a/net/gnome-netstatus/Makefile b/net/gnome-netstatus/Makefile
index 5c8a5647d921..c903839e594d 100644
--- a/net/gnome-netstatus/Makefile
+++ b/net/gnome-netstatus/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnomenetstatus
PORTVERSION= 2.12.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-netstatus/2.12
diff --git a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
index bf655bd6a0a8..b674048d5ef2 100644
--- a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
+++ b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
@@ -1,5 +1,19 @@
---- src/netstatus-sysdeps.c.orig Mon Jun 27 14:29:53 2005
-+++ src/netstatus-sysdeps.c Mon Jun 27 14:30:18 2005
+--- src/netstatus-sysdeps.c.orig Mon Mar 14 09:34:06 2005
++++ src/netstatus-sysdeps.c Mon Jan 30 21:44:49 2006
+@@ -430,11 +430,11 @@ static inline char *
+ get_an_data (const char *iface,
+ int *signal_strength)
+ {
++ struct an_ltv_status *sts;
++ struct an_req areq;
+ #ifdef AN_RID_RSSI_MAP
+ struct an_ltv_rssi_map an_rssimap;
+ #endif
+- struct an_req areq;
+- struct an_ltv_status *sts;
+ int level;
+ char *error = NULL;
+ gboolean rssimap_valid = FALSE;
@@ -548,6 +548,8 @@ netstatus_sysdeps_read_iface_wireless_de
g_strncasecmp (iface, "wi", 2) &&
g_strncasecmp (iface, "ath", 3) &&