aboutsummaryrefslogtreecommitdiff
path: root/net/gq/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-08-15 14:49:02 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-08-15 14:49:02 +0000
commit8181a79f6eaf30e9ddc1b7057031b4a02e8a2bc0 (patch)
tree407942b149d45d23547adc54c98674ecc08a8b25 /net/gq/Makefile
parent162005da10697658d339786f145fd890fd58a2e5 (diff)
downloadports-8181a79f6eaf30e9ddc1b7057031b4a02e8a2bc0.tar.gz
ports-8181a79f6eaf30e9ddc1b7057031b4a02e8a2bc0.zip
- Update to 1.2.2
- Use macro from bsd.sites.mk - Remove USE_GCC as we have 3.4 in all supported version - Update WWW entry PR: ports/115393 Submitted by: KATO Tsuguru <tkato432 at yahoo.com>
Notes
Notes: svn path=/head/; revision=197749
Diffstat (limited to 'net/gq/Makefile')
-rw-r--r--net/gq/Makefile36
1 files changed, 13 insertions, 23 deletions
diff --git a/net/gq/Makefile b/net/gq/Makefile
index 624fa58a8169..603626bc675e 100644
--- a/net/gq/Makefile
+++ b/net/gq/Makefile
@@ -6,44 +6,34 @@
#
PORTNAME= gq
-PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTVERSION= 1.2.2
PORTEPOCH= 1
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://dryice.name/computer/FreeBSD/distfiles/
-MASTER_SITE_SUBDIR= gqclient
-DISTNAME= gq-${PORTVERSION:S/r/rc/}
+MASTER_SITES= SF/gqclient
MAINTAINER= ports@FreeBSD.org
COMMENT= GTK-based LDAP client
LIB_DEPENDS= gnome-keyring:${PORTSDIR}/security/gnome-keyring
-USE_GCC= 3.4+
-USE_GMAKE= yes
-USE_ICONV= yes
-USE_GETTEXT= yes
-USE_OPENLDAP= yes
-USE_OPENSSL= yes
+OPTIONS= DND "Enable Drag and drop support in browse mode" On \
+ CACHE "Support the OpenLDAP experimental client cache" On
+
+USE_GNOME= gnomehier gnometarget libglade2
USE_XLIB= yes
-USE_GNOME= gnomehier gtk20 libxml2 libglade2 intltool
+USE_OPENSSL= yes
+USE_OPENLDAP= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-ldap-prefix=${LOCALBASE}
-OPTIONS= JPEG "Enable jpegPhoto attr. handling" On \
- DND "Enable Drag and drop support in browse mode" On \
- CACHE "Support the OpenLDAP experimental client cache" On
-
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_JPEG)
-USE_GNOME+= gdkpixbuf
-.endif
-
.if !defined(WITHOUT_DND)
CONFIGURE_ARGS+= --enable-browser-dnd
.endif