aboutsummaryrefslogtreecommitdiff
path: root/net/gspoof/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-29 04:17:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-29 04:17:37 +0000
commitb0802091e00d6735b6d6cda0a7509e1f9fed2645 (patch)
tree43d5eefa19d61b4d20d74527c70a454cac668da4 /net/gspoof/Makefile
parent74f0872c5b982e0ba326b19c22a9901e999e6947 (diff)
downloadports-b0802091e00d6735b6d6cda0a7509e1f9fed2645.tar.gz
ports-b0802091e00d6735b6d6cda0a7509e1f9fed2645.zip
add gspoof 2.1.1
Console/GTK+ TCP/IP Packets Forger
Notes
Notes: svn path=/head/; revision=74195
Diffstat (limited to 'net/gspoof/Makefile')
-rw-r--r--net/gspoof/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net/gspoof/Makefile b/net/gspoof/Makefile
new file mode 100644
index 000000000000..4e90cdbbeccd
--- /dev/null
+++ b/net/gspoof/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: gspoof
+# Date created: Jan 29, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gspoof
+PORTVERSION= 2.1.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
+
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= gtk
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|gtk-config|${GTK_CONFIG}|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gspoof ${PREFIX}/bin
+
+.include <bsd.port.mk>