aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2017-10-23 12:20:36 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2017-10-23 12:20:36 +0000
commit115497180bb782d407526904268ff7a401162bd5 (patch)
tree7fa123071367e3dbaa58049aef124f0132d4db39 /net/haproxy/Makefile
parent5fa3c6360f4187016b3b0d99175fe389082d13e1 (diff)
downloadports-115497180bb782d407526904268ff7a401162bd5.tar.gz
ports-115497180bb782d407526904268ff7a401162bd5.zip
Pull deviceatlas library from a (recently created) separate port.
Submitted by: David Carlier <dcarlier@afilias.info>
Notes
Notes: svn path=/head/; revision=452702
Diffstat (limited to 'net/haproxy/Makefile')
-rw-r--r--net/haproxy/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 81ac0852b88d..3df24cc28e09 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -18,10 +18,6 @@ CONFLICTS_INSTALL= haproxy-devel-[0-9]*
USES= cpe gmake
USE_RC_SUBR= haproxy
-DEVICEATLAS_VERSION= 2.1.2_2
-DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
-DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
-
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_ACCEPT4=1 \
CC="${CC}" DEBUG_CFLAGS="" CPU_CFLAGS="${CFLAGS}"
@@ -47,16 +43,8 @@ MAKE_ARGS+= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
.endif
.if ${PORT_OPTIONS:MDEVICEATLAS}
-.if !exists(${DISTDIR}/${DEVICEATLAS_DISTFILE}.tgz)
-IGNORE?= you must manually fetch the DeviceAtlas Device Detection C API from ${DEVICEATLAS_REGISTRATION_URL} and place it in ${DISTDIR} and then run make again
-.else
-RESTRICTED= The redistribution of the DeviceAtlas Device Detection C API is not permitted
-DISTFILES+= ${DEVICEATLAS_DISTFILE}.tgz
-MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_SRC=${WRKDIR}/deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}/Src
-.endif
-.if ! ${PORT_OPTIONS:MDPCRE} && ! ${PORT_OPTIONS:MSPCRE}
-IGNORE?= enable PCRE support to use DeviceAtlas
-.endif
+LIB_DEPENDS+= libda.so:net/deviceatlas-enterprise-c
+MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include
.endif
.if ${PORT_OPTIONS:MOPENSSL}