aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2017-04-19 12:57:56 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2017-04-19 12:57:56 +0000
commit2db870881c9a5bbc09e6f1ac07717e034436ca09 (patch)
tree2b93c5c94375b794011553e57942d55515137b6d /net/haproxy/Makefile
parent8283956ce48512bb213db1673d5c3fc87680038c (diff)
downloadports-2db870881c9a5bbc09e6f1ac07717e034436ca09.tar.gz
ports-2db870881c9a5bbc09e6f1ac07717e034436ca09.zip
Do not override CFLAGS defined in Makefile; use OPTIONS_CFLAGS to pass our
CFLAGS env variable; Add -fwrap to CFLAGS to fix eventual haproxy spins when compiled with newer versions of clang (FreeBSD-11 is affected). -- obtained from haproxy source tree.
Notes
Notes: svn path=/head/; revision=438838
Diffstat (limited to 'net/haproxy/Makefile')
-rw-r--r--net/haproxy/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 2e086285e961..45e535d8fef4 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -23,7 +23,7 @@ DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" CFLAGS="${CFLAGS}"
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 CC="${CC}" DEBUG_CFLAGS="" OPTIONS_CFLAGS="${CFLAGS}"
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE