aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2006-11-01 14:42:14 +0000
committerClement Laforet <clement@FreeBSD.org>2006-11-01 14:42:14 +0000
commitfa1931b038fdb787765737a6329abc6e193ae934 (patch)
tree45c125988189e92c4929d28d7197294dc245eb91 /net/haproxy
parentbe2bd16f64eb09c2502cdf37f2ed8a2cf0a7c6b9 (diff)
downloadports-fa1931b038fdb787765737a6329abc6e193ae934.tar.gz
ports-fa1931b038fdb787765737a6329abc6e193ae934.zip
- Update to 1.2.16
- use USE_RC_SUBR and tweak haproxy.sh
Notes
Notes: svn path=/head/; revision=176079
Diffstat (limited to 'net/haproxy')
-rw-r--r--net/haproxy/Makefile10
-rw-r--r--net/haproxy/distinfo6
-rw-r--r--net/haproxy/files/haproxy.sh.in (renamed from net/haproxy/files/haproxy.sh)4
3 files changed, 7 insertions, 13 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 78cff85ea703..71ae2a1aaaab 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -6,15 +6,14 @@
#
PORTNAME= haproxy
-PORTVERSION= 1.2.15
+PORTVERSION= 1.2.16
CATEGORIES= net www
MASTER_SITES= http://haproxy.1wt.eu/download/1.2/src/
MAINTAINER= clement@FreeBSD.org
COMMENT= High-performance and highly-robust TCP/HTTP load balancer
-USE_RC_SUBR= yes
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+USE_RC_SUBR= haproxy.sh
STATS_INTERVAL?= 0
CFLAGS+= -DSTATTIME=${STATS_INTERVAL}
@@ -49,14 +48,9 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's!localtime(!localtime((time_t *)!' ${WRKSRC}/haproxy.c
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/haproxy.sh > ${WRKDIR}/haproxy.sh
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/haproxy ${PREFIX}/sbin
- @${INSTALL_SCRIPT} ${WRKDIR}/haproxy.sh \
- ${PREFIX}/etc/rc.d/haproxy.sh
-
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${MKDIR} ${EXAMPLESDIR}
diff --git a/net/haproxy/distinfo b/net/haproxy/distinfo
index 4473cf674fd5..1a06fc6b8296 100644
--- a/net/haproxy/distinfo
+++ b/net/haproxy/distinfo
@@ -1,3 +1,3 @@
-MD5 (haproxy-1.2.15.tar.gz) = 7461a3deeda099a6ee190f99e9763fea
-SHA256 (haproxy-1.2.15.tar.gz) = 196fa8762dc644cbe97f9abf16c260d342b4a0f1e90446a413b839c6aae4db77
-SIZE (haproxy-1.2.15.tar.gz) = 248300
+MD5 (haproxy-1.2.16.tar.gz) = f72c44bcddf868edf4000503be09a12d
+SHA256 (haproxy-1.2.16.tar.gz) = c8635aaf761f3bb74676d6cbc1ebb415cdcebebcdb46261a737a7d69c4251f2f
+SIZE (haproxy-1.2.16.tar.gz) = 197867
diff --git a/net/haproxy/files/haproxy.sh b/net/haproxy/files/haproxy.sh.in
index a69868ffb1e8..17682a730f73 100644
--- a/net/haproxy/files/haproxy.sh
+++ b/net/haproxy/files/haproxy.sh.in
@@ -1,6 +1,6 @@
#!/bin/sh
#
-# $FreeBSD$
+# $FreeBSD: /tmp/pcvs/ports/net/haproxy/files/Attic/haproxy.sh.in,v 1.1 2006-11-01 14:42:14 clement Exp $
#
# PROVIDE: haproxy
@@ -30,7 +30,7 @@ pidfile="/var/run/haproxy.pid"
required_files=%%PREFIX%%/etc/haproxy.conf
[ -z "$haproxy_enable" ] && haproxy_enable="NO"
-[ -z "$haproxy_flags" ] && haproxy_flags="-p ${pidfile}"
+[ -z "$haproxy_flags" ] && haproxy_flags="-p ${pidfile} -f /usr/local/etc/haproxy.conf"
[ -z "$haproxylimits_enable" ] && haproxylimits_enable="NO"
[ -z "$haproxylimits_args" ] && haproxylimits_args="-e -C daemon"