aboutsummaryrefslogtreecommitdiff
path: root/net/hawknl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /net/hawknl
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'net/hawknl')
-rw-r--r--net/hawknl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net/hawknl/Makefile b/net/hawknl/Makefile
index dd94069bddd2..c61376e3cfbe 100644
--- a/net/hawknl/Makefile
+++ b/net/hawknl/Makefile
@@ -18,10 +18,10 @@ COMMENT= Portable networking library
USE_DOS2UNIX= yes
USE_GMAKE= yes
MAKEFILE= makefile.linux
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS= -I${LOCALBASE}/include
MAKE_ENV= CC="${CC}" CFLAGS="${CFLAGS} ${OPTFLAGS}" \
LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"