aboutsummaryrefslogtreecommitdiff
path: root/net/honeyd
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-12-04 16:00:46 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-12-04 16:00:46 +0000
commit12a1b99c1f99276a8bc6382d401bf76f487d035e (patch)
tree3a4af356bda074e333f4d4cbbf3fabc7216c226a /net/honeyd
parent4acf0ca1a968e9be16535078256276dd2cd16329 (diff)
downloadports-12a1b99c1f99276a8bc6382d401bf76f487d035e.tar.gz
ports-12a1b99c1f99276a8bc6382d401bf76f487d035e.zip
- Update to 0.7
- Install sample scripts in DATADIR - Clarify and shorten COMMENT - Make Python dependency optional - add WITH_PYTHON knob PR: 59727 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=95019
Diffstat (limited to 'net/honeyd')
-rw-r--r--net/honeyd/Makefile36
-rw-r--r--net/honeyd/distinfo2
-rw-r--r--net/honeyd/pkg-plist31
3 files changed, 57 insertions, 12 deletions
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index 206f0f7f2520..78b63f063d43 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -6,22 +6,52 @@
#
PORTNAME= honeyd
-PORTVERSION= 0.6a
+PORTVERSION= 0.7
CATEGORIES= net
MASTER_SITES= http://niels.xtdnet.nl/honeyd/
MAINTAINER= yb@sainte-barbe.org
-COMMENT= A utility to simualte services and hosts on a virtual network host
+COMMENT= Simulate virtual network hosts (honeypots)
BUILD_DEPENDS= ${LOCALBASE}/lib/libdnet.a:${PORTSDIR}/net/libdnet \
${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libdnet=${LOCALBASE} \
--with-libevent=${LOCALBASE} \
--with-pcap
-INSTALLS_SHLIB= yes
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+CONFIGURE_ARGS+= --with-python
+.else
+CONFIGURE_ARGS+= --without-python
+.endif
+
MAN8= honeyd.8
+.if !defined(WITH_PYTHON)
+pre-everything::
+ @${ECHO_MSG} "===>"
+ @${ECHO_MSG} "===> You can enable Python support by defining the following variable:"
+ @${ECHO_MSG} "===> WITH_PYTHON=yes Enable Python support"
+ @${ECHO_MSG} "===>"
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|LIBS = |LIBS = ${PTHREAD_LIBS}|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ @${MKDIR} ${DATADIR}/scripts/snmp
+ @cd ${WRKSRC}/scripts && \
+ ${INSTALL_SCRIPT} *.pl *.sh ${DATADIR}/scripts
+ @cd ${WRKSRC}/scripts/snmp && \
+ ${INSTALL_DATA} README default.snmp *.tpl \
+ ${DATADIR}/scripts/snmp && \
+ ${INSTALL_SCRIPT} *.pl ${DATADIR}/scripts/snmp
+
.include <bsd.port.mk>
diff --git a/net/honeyd/distinfo b/net/honeyd/distinfo
index 60dd6ee5e327..59f428a6897a 100644
--- a/net/honeyd/distinfo
+++ b/net/honeyd/distinfo
@@ -1 +1 @@
-MD5 (honeyd-0.6a.tar.gz) = d8743bde540db637a7cd7a19214a8265
+MD5 (honeyd-0.7.tar.gz) = d05e112d513d0a1ce7b39cded9b0aba5
diff --git a/net/honeyd/pkg-plist b/net/honeyd/pkg-plist
index 56154c83f2a2..e846a8bb0113 100644
--- a/net/honeyd/pkg-plist
+++ b/net/honeyd/pkg-plist
@@ -1,14 +1,29 @@
+@comment $FreeBSD$
bin/honeyd
+include/honeyd/debug.h
include/honeyd/hooks.h
include/honeyd/plugins.h
include/honeyd/plugins_config.h
-include/honeyd/debug.h
-share/honeyd/README
-share/honeyd/nmap.assoc
-share/honeyd/nmap.prints
-share/honeyd/xprobe2.conf
-share/honeyd/config.sample
-@dirrm share/honeyd
+@dirrm include/honeyd
lib/honeyd/libhoneyd.so
@dirrm lib/honeyd
-@dirrm include/honeyd
+%%DATADIR%%/README
+%%DATADIR%%/nmap.assoc
+%%DATADIR%%/nmap.prints
+%%DATADIR%%/xprobe2.conf
+%%DATADIR%%/config.sample
+%%DATADIR%%/pf.os
+%%DATADIR%%/scripts/proxy.pl
+%%DATADIR%%/scripts/router-telnet.pl
+%%DATADIR%%/scripts/smtp.pl
+%%DATADIR%%/scripts/test.sh
+%%DATADIR%%/scripts/web.sh
+%%DATADIR%%/scripts/snmp/README
+%%DATADIR%%/scripts/snmp/buildSNMPConfig.pl
+%%DATADIR%%/scripts/snmp/default.snmp
+%%DATADIR%%/scripts/snmp/fake-snmp.pl
+%%DATADIR%%/scripts/snmp/linux-2.4.snmp.tpl
+%%DATADIR%%/scripts/snmp/windows2000.snmp.tpl
+@dirrm %%DATADIR%%/scripts/snmp
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%