aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-09-23 18:20:11 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-09-23 18:20:11 +0000
commit960c48e8f320e94f1bced21f6ec61ce55d252599 (patch)
treee5932dc0a64ddc8acbd3ca1d549c2c6242dcdaf5 /net/hostapd
parent705518dabac276c2af9d8985c1af39e0bc3e8c37 (diff)
downloadports-960c48e8f320e94f1bced21f6ec61ce55d252599.tar.gz
ports-960c48e8f320e94f1bced21f6ec61ce55d252599.zip
Update to 2.5
PR: 212779 Submitted by: leres at ee.lbl.gov (maintainer)
Notes
Notes: svn path=/head/; revision=422688
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile3
-rw-r--r--net/hostapd/distinfo5
-rw-r--r--net/hostapd/files/patch-src_ap_wmm.c12
-rw-r--r--net/hostapd/files/patch-src_drivers_driver__bsd.c14
-rw-r--r--net/hostapd/files/patch-src_eap__peer_eap__pwd.c77
-rw-r--r--net/hostapd/files/patch-src_eap__server_eap__server__pwd.c60
-rw-r--r--net/hostapd/files/patch-src_utils_os.h17
-rw-r--r--net/hostapd/files/patch-src_utils_os__unix.c18
-rw-r--r--net/hostapd/files/patch-src_wps_httpread.c16
9 files changed, 39 insertions, 183 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index bd93e7dd6f8f..bc447d190187 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= hostapd
-PORTVERSION= 2.4
-PORTREVISION= 2
+PORTVERSION= 2.5
CATEGORIES= net
MASTER_SITES= http://w1.fi/releases/
diff --git a/net/hostapd/distinfo b/net/hostapd/distinfo
index 834f426ca46d..108d93cbced9 100644
--- a/net/hostapd/distinfo
+++ b/net/hostapd/distinfo
@@ -1,2 +1,3 @@
-SHA256 (hostapd-2.4.tar.gz) = 6fe0eb6bd1c9cbd24952ece8586b6f7bd14ab358edfda99794e79b9b9dbd657f
-SIZE (hostapd-2.4.tar.gz) = 1658872
+TIMESTAMP = 1467776602
+SHA256 (hostapd-2.5.tar.gz) = 8e272d954dc0d7026c264b79b15389ec2b2c555b32970de39f506b9f463ec74a
+SIZE (hostapd-2.5.tar.gz) = 1720783
diff --git a/net/hostapd/files/patch-src_ap_wmm.c b/net/hostapd/files/patch-src_ap_wmm.c
deleted file mode 100644
index 3da758573de3..000000000000
--- a/net/hostapd/files/patch-src_ap_wmm.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/ap/wmm.c.orig 2015-03-15 17:30:39 UTC
-+++ src/ap/wmm.c
-@@ -274,6 +274,9 @@ void hostapd_wmm_action(struct hostapd_d
- return;
- }
-
-+ if (left < 0)
-+ return; /* not a valid WMM Action frame */
-+
- /* extract the tspec info element */
- if (ieee802_11_parse_elems(pos, left, &elems, 1) == ParseFailed) {
- hostapd_logger(hapd, mgmt->sa, HOSTAPD_MODULE_IEEE80211,
diff --git a/net/hostapd/files/patch-src_drivers_driver__bsd.c b/net/hostapd/files/patch-src_drivers_driver__bsd.c
deleted file mode 100644
index 28bf4da9671d..000000000000
--- a/net/hostapd/files/patch-src_drivers_driver__bsd.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/drivers/driver_bsd.c.orig 2015-03-15 17:30:39 UTC
-+++ src/drivers/driver_bsd.c
-@@ -623,7 +623,11 @@ rtbuf_len(void)
- static int bsd_sta_deauth(void *priv, const u8 *own_addr, const u8 *addr,
- int reason_code);
-
-+#ifdef __DragonFly__
-+const char *
-+#else
- static const char *
-+#endif
- ether_sprintf(const u8 *addr)
- {
- static char buf[sizeof(MACSTR)];
diff --git a/net/hostapd/files/patch-src_eap__peer_eap__pwd.c b/net/hostapd/files/patch-src_eap__peer_eap__pwd.c
deleted file mode 100644
index e3910df59c0b..000000000000
--- a/net/hostapd/files/patch-src_eap__peer_eap__pwd.c
+++ /dev/null
@@ -1,77 +0,0 @@
---- src/eap_peer/eap_pwd.c.orig 2015-03-15 17:30:39 UTC
-+++ src/eap_peer/eap_pwd.c
-@@ -301,6 +301,23 @@ eap_pwd_perform_commit_exchange(struct e
- BIGNUM *mask = NULL, *x = NULL, *y = NULL, *cofactor = NULL;
- u16 offset;
- u8 *ptr, *scalar = NULL, *element = NULL;
-+ size_t prime_len, order_len;
-+
-+ if (data->state != PWD_Commit_Req) {
-+ ret->ignore = TRUE;
-+ goto fin;
-+ }
-+
-+ prime_len = BN_num_bytes(data->grp->prime);
-+ order_len = BN_num_bytes(data->grp->order);
-+
-+ if (payload_len != 2 * prime_len + order_len) {
-+ wpa_printf(MSG_INFO,
-+ "EAP-pwd: Unexpected Commit payload length %u (expected %u)",
-+ (unsigned int) payload_len,
-+ (unsigned int) (2 * prime_len + order_len));
-+ goto fin;
-+ }
-
- if (((data->private_value = BN_new()) == NULL) ||
- ((data->my_element = EC_POINT_new(data->grp->group)) == NULL) ||
-@@ -500,6 +517,18 @@ eap_pwd_perform_confirm_exchange(struct
- u8 conf[SHA256_MAC_LEN], *cruft = NULL, *ptr;
- int offset;
-
-+ if (data->state != PWD_Confirm_Req) {
-+ ret->ignore = TRUE;
-+ goto fin;
-+ }
-+
-+ if (payload_len != SHA256_MAC_LEN) {
-+ wpa_printf(MSG_INFO,
-+ "EAP-pwd: Unexpected Confirm payload length %u (expected %u)",
-+ (unsigned int) payload_len, SHA256_MAC_LEN);
-+ goto fin;
-+ }
-+
- /*
- * first build up the ciphersuite which is group | random_function |
- * prf
-@@ -783,11 +812,23 @@ eap_pwd_process(struct eap_sm *sm, void
- * if it's the first fragment there'll be a length field
- */
- if (EAP_PWD_GET_LENGTH_BIT(lm_exch)) {
-+ if (len < 2) {
-+ wpa_printf(MSG_DEBUG,
-+ "EAP-pwd: Frame too short to contain Total-Length field");
-+ ret->ignore = TRUE;
-+ return NULL;
-+ }
- tot_len = WPA_GET_BE16(pos);
- wpa_printf(MSG_DEBUG, "EAP-pwd: Incoming fragments whose "
- "total length = %d", tot_len);
- if (tot_len > 15000)
- return NULL;
-+ if (data->inbuf) {
-+ wpa_printf(MSG_DEBUG,
-+ "EAP-pwd: Unexpected new fragment start when previous fragment is still in use");
-+ ret->ignore = TRUE;
-+ return NULL;
-+ }
- data->inbuf = wpabuf_alloc(tot_len);
- if (data->inbuf == NULL) {
- wpa_printf(MSG_INFO, "Out of memory to buffer "
-@@ -873,6 +914,7 @@ eap_pwd_process(struct eap_sm *sm, void
- /*
- * we have output! Do we need to fragment it?
- */
-+ lm_exch = EAP_PWD_GET_EXCHANGE(lm_exch);
- len = wpabuf_len(data->outbuf);
- if ((len + EAP_PWD_HDR_SIZE) > data->mtu) {
- resp = eap_msg_alloc(EAP_VENDOR_IETF, EAP_TYPE_PWD, data->mtu,
diff --git a/net/hostapd/files/patch-src_eap__server_eap__server__pwd.c b/net/hostapd/files/patch-src_eap__server_eap__server__pwd.c
deleted file mode 100644
index ddc2b99c766d..000000000000
--- a/net/hostapd/files/patch-src_eap__server_eap__server__pwd.c
+++ /dev/null
@@ -1,60 +0,0 @@
---- src/eap_server/eap_server_pwd.c.orig 2015-03-15 17:30:39 UTC
-+++ src/eap_server/eap_server_pwd.c
-@@ -634,9 +634,21 @@ eap_pwd_process_commit_resp(struct eap_s
- BIGNUM *x = NULL, *y = NULL, *cofactor = NULL;
- EC_POINT *K = NULL, *point = NULL;
- int res = 0;
-+ size_t prime_len, order_len;
-
- wpa_printf(MSG_DEBUG, "EAP-pwd: Received commit response");
-
-+ prime_len = BN_num_bytes(data->grp->prime);
-+ order_len = BN_num_bytes(data->grp->order);
-+
-+ if (payload_len != 2 * prime_len + order_len) {
-+ wpa_printf(MSG_INFO,
-+ "EAP-pwd: Unexpected Commit payload length %u (expected %u)",
-+ (unsigned int) payload_len,
-+ (unsigned int) (2 * prime_len + order_len));
-+ goto fin;
-+ }
-+
- if (((data->peer_scalar = BN_new()) == NULL) ||
- ((data->k = BN_new()) == NULL) ||
- ((cofactor = BN_new()) == NULL) ||
-@@ -752,6 +764,13 @@ eap_pwd_process_confirm_resp(struct eap_
- u8 conf[SHA256_MAC_LEN], *cruft = NULL, *ptr;
- int offset;
-
-+ if (payload_len != SHA256_MAC_LEN) {
-+ wpa_printf(MSG_INFO,
-+ "EAP-pwd: Unexpected Confirm payload length %u (expected %u)",
-+ (unsigned int) payload_len, SHA256_MAC_LEN);
-+ goto fin;
-+ }
-+
- /* build up the ciphersuite: group | random_function | prf */
- grp = htons(data->group_num);
- ptr = (u8 *) &cs;
-@@ -901,11 +920,21 @@ static void eap_pwd_process(struct eap_s
- * the first fragment has a total length
- */
- if (EAP_PWD_GET_LENGTH_BIT(lm_exch)) {
-+ if (len < 2) {
-+ wpa_printf(MSG_DEBUG,
-+ "EAP-pwd: Frame too short to contain Total-Length field");
-+ return;
-+ }
- tot_len = WPA_GET_BE16(pos);
- wpa_printf(MSG_DEBUG, "EAP-pwd: Incoming fragments, total "
- "length = %d", tot_len);
- if (tot_len > 15000)
- return;
-+ if (data->inbuf) {
-+ wpa_printf(MSG_DEBUG,
-+ "EAP-pwd: Unexpected new fragment start when previous fragment is still in use");
-+ return;
-+ }
- data->inbuf = wpabuf_alloc(tot_len);
- if (data->inbuf == NULL) {
- wpa_printf(MSG_INFO, "EAP-pwd: Out of memory to "
diff --git a/net/hostapd/files/patch-src_utils_os.h b/net/hostapd/files/patch-src_utils_os.h
new file mode 100644
index 000000000000..fb6e7f50e74e
--- /dev/null
+++ b/net/hostapd/files/patch-src_utils_os.h
@@ -0,0 +1,17 @@
+--- src/utils/os.h.orig 2016-09-17 20:36:13 UTC
++++ src/utils/os.h
+@@ -246,12 +246,14 @@ char * os_readfile(const char *name, siz
+ */
+ int os_file_exists(const char *fname);
+
++#ifndef __FreeBSD__
+ /**
+ * os_fdatasync - Sync a file's (for a given stream) state with storage device
+ * @stream: the stream to be flushed
+ * Returns: 0 if the operation succeeded or -1 on failure
+ */
+ int os_fdatasync(FILE *stream);
++#endif
+
+ /**
+ * os_zalloc - Allocate and zero memory
diff --git a/net/hostapd/files/patch-src_utils_os__unix.c b/net/hostapd/files/patch-src_utils_os__unix.c
new file mode 100644
index 000000000000..3d6fb5f543dc
--- /dev/null
+++ b/net/hostapd/files/patch-src_utils_os__unix.c
@@ -0,0 +1,18 @@
+--- src/utils/os_unix.c.orig 2015-09-27 19:02:05 UTC
++++ src/utils/os_unix.c
+@@ -442,6 +442,7 @@ int os_file_exists(const char *fname)
+ }
+
+
++#ifndef __FreeBSD__
+ int os_fdatasync(FILE *stream)
+ {
+ if (!fflush(stream)) {
+@@ -459,6 +460,7 @@ int os_fdatasync(FILE *stream)
+
+ return -1;
+ }
++#endif
+
+
+ #ifndef WPA_TRACE
diff --git a/net/hostapd/files/patch-src_wps_httpread.c b/net/hostapd/files/patch-src_wps_httpread.c
deleted file mode 100644
index dfdc89f2a8cd..000000000000
--- a/net/hostapd/files/patch-src_wps_httpread.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/wps/httpread.c.orig 2015-03-15 17:30:39 UTC
-+++ src/wps/httpread.c
-@@ -533,6 +533,13 @@ static void httpread_read_handler(int sd
- if (!isxdigit(*cbp))
- goto bad;
- h->chunk_size = strtoul(cbp, NULL, 16);
-+ if (h->chunk_size < 0 ||
-+ h->chunk_size > h->max_bytes) {
-+ wpa_printf(MSG_DEBUG,
-+ "httpread: Invalid chunk size %d",
-+ h->chunk_size);
-+ goto bad;
-+ }
- /* throw away chunk header
- * so we have only real data
- */