aboutsummaryrefslogtreecommitdiff
path: root/net/htpdate
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-04-18 23:40:38 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-04-18 23:40:38 +0000
commitab571e92ec33e9fbf44e9e3e1cec53cc322d710a (patch)
treec137baf819e86d3153a7d1f46aed2b56bed29ff2 /net/htpdate
parentdaa0cf296c85ea6ed1ecac1c77cae1a11911f2ce (diff)
downloadports-ab571e92ec33e9fbf44e9e3e1cec53cc322d710a.tar.gz
ports-ab571e92ec33e9fbf44e9e3e1cec53cc322d710a.zip
- update to 1.0.5 [1]
- adjust MASTER_SITES and project site (pkg-descr) [1] - while here add documentation support and rc service script - take maintainership Suggested by: eddy.vervest@xs4all.nl, software author [1] Feature safe: yes
Notes
Notes: svn path=/head/; revision=316081
Diffstat (limited to 'net/htpdate')
-rw-r--r--net/htpdate/Makefile23
-rw-r--r--net/htpdate/distinfo4
-rw-r--r--net/htpdate/files/htpdate.in43
-rw-r--r--net/htpdate/pkg-descr2
4 files changed, 60 insertions, 12 deletions
diff --git a/net/htpdate/Makefile b/net/htpdate/Makefile
index b04048a8b881..40395a1573b1 100644
--- a/net/htpdate/Makefile
+++ b/net/htpdate/Makefile
@@ -1,18 +1,13 @@
-# New ports collection makefile for: htpdate
-# Date created: 9 Jun 2005
-# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
-#
+# Created by: Vsevolod Stakhov <vsevolod@highsecure.ru>
# $FreeBSD$
-#
PORTNAME= htpdate
-PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTVERSION= 1.0.5
CATEGORIES= net ipv6
-MASTER_SITES= http://www.clevervest.com/htp/archive/c/ \
+MASTER_SITES= http://www.vervest.org/htp/archive/c/ \
http://twekkel.home.xs4all.nl/htp/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jgh@FreeBSD.org
COMMENT= Time synchronization over http utility
LICENSE= GPLv2 # (or later)
@@ -23,9 +18,19 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
MANCOMPRESSED= yes
MAN8= ${PORTNAME}.8
PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= Changelog README
+USE_RC_SUBR= ${PORTNAME}
+
+.include <bsd.port.options.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8.gz ${MAN8PREFIX}/man/man8
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/net/htpdate/distinfo b/net/htpdate/distinfo
index 7b1ff07e6fc3..c1ae48564bb7 100644
--- a/net/htpdate/distinfo
+++ b/net/htpdate/distinfo
@@ -1,2 +1,2 @@
-SHA256 (htpdate-1.0.4.tar.bz2) = 2e1a4c0cc3a2f489b73b2f15f009067eb41af5a865e3d5701ba00f5cfb70ab57
-SIZE (htpdate-1.0.4.tar.bz2) = 16214
+SHA256 (htpdate-1.0.5.tar.bz2) = 80a714bf5222e05d88c673099ce3b1207d88db105a5ae6c761de0b2439528d73
+SIZE (htpdate-1.0.5.tar.bz2) = 16377
diff --git a/net/htpdate/files/htpdate.in b/net/htpdate/files/htpdate.in
new file mode 100644
index 000000000000..0a2e54476722
--- /dev/null
+++ b/net/htpdate/files/htpdate.in
@@ -0,0 +1,43 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+# PROVIDE: htpdate
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+# Add the following line to /etc/rc.conf to enable htpdate:
+#
+# htpdate_enable="YES"
+
+
+. /etc/rc.subr
+
+load_rc_config htpdate
+
+htpdate_enable="${htpdate_enable:-"NO"}"
+htpdate_servers="${htpdate_servers:-"www.freebsd.org www.linux.com"}"
+
+name=htpdate
+rcvar=htpdate_enable
+servers=${htpdate_servers}
+pidfile=/var/run/htpdate.pid
+
+command="/usr/local/bin/htpdate"
+command_args="-l -s -D $servers"
+stop_cmd=htpdate_stop
+
+htpdate_stop ()
+{
+ if [ -f ${pidfile} ]; then
+ echo "Stopping htpdate."
+ kill `cat ${pidfile}`
+ else
+ echo "htpdate is not running."
+ fi
+
+ rm -f ${pidfile}
+}
+
+run_rc_command "$1"
diff --git a/net/htpdate/pkg-descr b/net/htpdate/pkg-descr
index 3f8c4339c00b..f64020004c07 100644
--- a/net/htpdate/pkg-descr
+++ b/net/htpdate/pkg-descr
@@ -6,4 +6,4 @@ computer synchronized.
Accuracy of htpdate is usually better than 0.5 seconds (even better with
multiple servers). Htpdate can also work through http proxy.
-WWW: http://www.clevervest.com/htp/
+WWW: http://www.vervest.org/htp/