aboutsummaryrefslogtreecommitdiff
path: root/net/incidenceeditor/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /net/incidenceeditor/Makefile
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'net/incidenceeditor/Makefile')
-rw-r--r--net/incidenceeditor/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/incidenceeditor/Makefile b/net/incidenceeditor/Makefile
index 51a394ae8418..66e61c5d14b8 100644
--- a/net/incidenceeditor/Makefile
+++ b/net/incidenceeditor/Makefile
@@ -12,7 +12,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libKGantt.so:graphics/kdiagram \
libboost_system.so:devel/boost-libs
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
i18n iconthemes itemmodels jobwidgets kio service sonnet \
textwidgets wallet widgetsaddons xmlgui
@@ -20,7 +20,7 @@ USE_KDE= auth codecs completion config configwidgets coreaddons ecm \
USE_KDE+= akonadi akonadicalendar akonadicontacts akonadimime calendarcore calendarsupport calendarutils \
contacts eventviews identitymanagement kdepim-apps-libs ldap \
libkdepim mailtransport mime pimtextedit
-USE_QT5= core dbus gui network printsupport testlib uitools webkit \
+USE_QT= core dbus gui network printsupport testlib uitools webkit \
widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes