aboutsummaryrefslogtreecommitdiff
path: root/net/ipsorc
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-08 20:05:26 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-08 20:05:26 +0000
commit3a887ab7f2edebfceafc319aa17086f12ee2d9e4 (patch)
tree7dbc627bce2d3301fceb71c18098aa5285869dc4 /net/ipsorc
parente022cdbdc5c121996a5fc09a6b1392cbac8c1297 (diff)
downloadports-3a887ab7f2edebfceafc319aa17086f12ee2d9e4.tar.gz
ports-3a887ab7f2edebfceafc319aa17086f12ee2d9e4.zip
ipsorc
A tool to create and send IP packets with a graphical GTK front-end PR: 32597 Submitted by: Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
Notes
Notes: svn path=/head/; revision=51233
Diffstat (limited to 'net/ipsorc')
-rw-r--r--net/ipsorc/Makefile35
-rw-r--r--net/ipsorc/distinfo1
-rw-r--r--net/ipsorc/files/patch-aa15
-rw-r--r--net/ipsorc/files/patch-ab11
-rw-r--r--net/ipsorc/pkg-comment1
-rw-r--r--net/ipsorc/pkg-descr8
-rw-r--r--net/ipsorc/pkg-plist3
7 files changed, 74 insertions, 0 deletions
diff --git a/net/ipsorc/Makefile b/net/ipsorc/Makefile
new file mode 100644
index 000000000000..850af7918233
--- /dev/null
+++ b/net/ipsorc/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ipsorc
+# Date created: 02 December, 2001
+# Whom: Nicolas.Jombart@hsc-labs.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipsorc
+PORTVERSION= 1.4
+CATEGORIES= net security
+MASTER_SITES= http://www.legions.org/~phric/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= Nicolas.Jombart@hsc-labs.com
+
+USE_GTK= yes
+
+post-patch:
+ @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.old
+ @${SED} s,gtk-config,${GTK_CONFIG}, < ${WRKSRC}/Makefile.old \
+ > ${WRKSRC}/Makefile
+ @${RM} ${WRKSRC}/Makefile.old
+
+do-install:
+.for file in ipmagic magic
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ipsorc/distinfo b/net/ipsorc/distinfo
new file mode 100644
index 000000000000..32a5b503500a
--- /dev/null
+++ b/net/ipsorc/distinfo
@@ -0,0 +1 @@
+MD5 (ipsorc-1.4.tar.gz) = 1a5472ae897b289ba07953386d26d1b3
diff --git a/net/ipsorc/files/patch-aa b/net/ipsorc/files/patch-aa
new file mode 100644
index 000000000000..27a6524aace3
--- /dev/null
+++ b/net/ipsorc/files/patch-aa
@@ -0,0 +1,15 @@
+--- spellbook.c Sun Dec 2 09:22:58 2001
++++ ../ipsorc-1.4.patch/spellbook.c Sun Dec 2 13:04:07 2001
+@@ -114,10 +114,10 @@
+ { type = ICMP_ECHOREPLY; }
+
+ else if(strstr(type_name, "Destination Unreachable"))
+- { type = ICMP_DEST_UNREACH; }
++ { type = ICMP_UNREACH_PORT; }
+
+ else if(strstr(type_name, "Source Quench"))
+- { type = ICMP_SOURCE_QUENCH; }
++ { type = ICMP_SOURCEQUENCH; }
+
+ else if(strstr(type_name, "Redirect"))
+ { type = ICMP_REDIRECT; }
diff --git a/net/ipsorc/files/patch-ab b/net/ipsorc/files/patch-ab
new file mode 100644
index 000000000000..a27a02dfc1e3
--- /dev/null
+++ b/net/ipsorc/files/patch-ab
@@ -0,0 +1,11 @@
+--- Makefile.orig Sun Dec 2 14:25:31 2001
++++ Makefile Sun Dec 2 14:25:45 2001
+@@ -6,6 +6,8 @@
+ CON = sorcery.c spells.c ipsorcery.c
+ #OBJS = $(SRC:.c=.o)
+
++all: con gtk
++
+ con:
+ $(CC) -g -O2 -Wall -ansi $(CON) -o ipmagic
+
diff --git a/net/ipsorc/pkg-comment b/net/ipsorc/pkg-comment
new file mode 100644
index 000000000000..e1c79a16cb85
--- /dev/null
+++ b/net/ipsorc/pkg-comment
@@ -0,0 +1 @@
+A tool to create and send IP packets with a graphical GTK front-end
diff --git a/net/ipsorc/pkg-descr b/net/ipsorc/pkg-descr
new file mode 100644
index 000000000000..7f18623e5e56
--- /dev/null
+++ b/net/ipsorc/pkg-descr
@@ -0,0 +1,8 @@
+IP Sorcery (ajs023@motorola.com) is a program that can generate IP packets
+(TCP, UDP, ICMP), with total control to fields, bits and data. It can work
+whitin the command line or a graphical frond-end written in GTK.
+IP Sorcery is useful to test program, firewalls, routers, etc.
+
+WWW: http://www.legions.org/~phric/ipsorcery.html
+
+--Nicolas Jombart <Nicolas.Jombart@hsc-labs.com>
diff --git a/net/ipsorc/pkg-plist b/net/ipsorc/pkg-plist
new file mode 100644
index 000000000000..a4b6be75efa5
--- /dev/null
+++ b/net/ipsorc/pkg-plist
@@ -0,0 +1,3 @@
+bin/ipmagic
+bin/magic
+%%PORTDOCS%%share/doc/ipsorc/README