aboutsummaryrefslogtreecommitdiff
path: root/net/isboot-kmod/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-09-24 10:28:58 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-09-24 10:28:58 +0000
commita8558b9e523a3853eefe3628d289a34bdb8dc7b8 (patch)
treeb743192b31cdb170ff472688a067902081c5dc70 /net/isboot-kmod/Makefile
parent9f3498e52a7db0c7264326da3e9c73c94ffdefd4 (diff)
downloadports-a8558b9e523a3853eefe3628d289a34bdb8dc7b8.tar.gz
ports-a8558b9e523a3853eefe3628d289a34bdb8dc7b8.zip
New port: net/isboot-kmod
This installs Daisuke Aoyama's isboot kernel module, which allows booting FreeBSD directly from an iSCSI root disk. If your BIOS supports iSCSI you may configure your target settings in the BIOS and boot directly. If not, you may PXE boot using software that contains iSCSI support such as iPXE. The module reads the iSCSI Boot Firmware Table (IBFT) to configure the network and re-attach the volume once the kernel begins execution. WWW: http://shell.peach.ne.jp/aoyama/archives/2115 (Japanese) PR: 203294 Submitted by: John Nielsen <john@jnielsen.net>
Notes
Notes: svn path=/head/; revision=397686
Diffstat (limited to 'net/isboot-kmod/Makefile')
-rw-r--r--net/isboot-kmod/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/isboot-kmod/Makefile b/net/isboot-kmod/Makefile
new file mode 100644
index 000000000000..f4f0d4c0bedc
--- /dev/null
+++ b/net/isboot-kmod/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= isboot-kmod
+PORTVERSION= 0.2.10
+CATEGORIES= net
+MASTER_SITES= http://www.peach.ne.jp/archives/isboot/
+DISTNAME= isboot-${PORTVERSION}
+
+MAINTAINER= john@jnielsen.net
+COMMENT= Kernel module enabling iSCSI boot
+
+LICENSE= BSD2CLAUSE
+
+USES= kmod uidfix
+SUB_FILES= pkg-message
+WRKSRC_SUBDIR= src
+PLIST_FILES= ${KMODDIR}/isboot.ko
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS VIMAGE
+VIMAGE_DESC= Build for a kernel with 'options VIMAGE'
+VIMAGE_CFLAGS= -DVIMAGE
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKDIR}/${DISTNAME} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>