aboutsummaryrefslogtreecommitdiff
path: root/net/kdenetwork4
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
commite9c34f4c34b0640b3613f03cd96e9f19730b2a07 (patch)
treeef2b2b24dfacf6def95c54d3379c421565b1fe2b /net/kdenetwork4
parent4dc7ccc95d370549c7c9c7c9c253d64aa92881ae (diff)
downloadports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.tar.gz
ports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.zip
KDE/FreeBSD team presents KDE SC 4.12.2 and KDE Workspace 4.11.6!
Among changes: - Switch KDE4_PREFIX to ${LOCALBASE} - Remove now needless misc/kde4-shared-mime-info port - Add stage support - Remove ancient CONFLICTS (KDE 4.9 and less) and LATEST_LINK - Squeeze MASTER_SITES/MASTER_SITE_SUBDIR - Convert LIB_DEPENDS to new style - Use options helpers - Drop support for FreeBSD 7.x - Remove Qt/KDE 3 related workarounds - Remove local patches and use upstream version scheme for libraries - sysutils/kdeadmin4, net/kdenetwork4, devel/kdesdk4, and x11-clocks/kdetoys4 ports have been split. - devel/kcachegrind is now a part of KDE SC [1] - more logs in area51 repo... New ports: devel/kde-dev-scripts: KDE development scripts devel/kde-dev-utils: KDE development utilities games/klickety: Tetris themed solitaire games/picmi: Single player logic-based puzzle game textproc/libkomparediff2: Library to compare files and strings The area51 repository features commits by Schaich Alonso, avilla, rakuco and myself. PR: ports/186491 Exp-run: by bdrewery Approved by: beat (former maintainer) [1]
Notes
Notes: svn path=/head/; revision=344893
Diffstat (limited to 'net/kdenetwork4')
-rw-r--r--net/kdenetwork4/Makefile76
-rw-r--r--net/kdenetwork4/distinfo2
-rw-r--r--net/kdenetwork4/files/patch-CMakeLists.txt10
-rw-r--r--net/kdenetwork4/files/patch-kget__transfer-plugins__bittorrent__CMakeLists.txt10
-rw-r--r--net/kdenetwork4/pkg-descr2
-rw-r--r--net/kdenetwork4/pkg-plist99
6 files changed, 28 insertions, 171 deletions
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 9e47d2f3d71e..ff63a190dca5 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -1,62 +1,40 @@
-# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
PORTNAME= kdenetwork
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
-CATEGORIES= net kde ipv6
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE/${PORTVERSION}
+CATEGORIES= net kde
+DISTFILES= #
MAINTAINER= kde@FreeBSD.org
-COMMENT= KDE Network applications
-
-LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca \
- libktorrent.so:${PORTSDIR}/net-p2p/libktorrent \
- libboost_thread.so:${PORTSDIR}/devel/boost-libs \
- libmms.so:${PORTSDIR}/net/libmms \
- libjpeg.so:${PORTSDIR}/graphics/jpeg
-RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
-
-LATEST_LINK= ${PORTNAME}4
-
-USE_KDE4= kdehier kdelibs kdeprefix libkonq pimlibs workspace \
- automoc4 ontologies strigi
-USES= cmake:outsource
-USE_OPENSSL= yes
-USE_QT4= corelib gui sql \
- moc_build qmake_build rcc_build uic_build
-USE_SQLITE= yes
-USE_XORG= x11 xdamage xext xscrnsaver xtst
-USE_XZ= yes
-USE_LDCONFIG= yes
-CONFIGURE_ENV= XDG_CONFIG_HOME=/dev/null
-MAKE_ENV= XDG_CONFIG_HOME=/dev/null
-
-CMAKE_ARGS+= -DBUILD_kopete=off \
- -DBUILD_krdc=off \
- -DBUILD_krfb=off
-
-OPTIONS_DEFINE= KOPETE KRDC KRFB
+COMMENT= KDE Network applications (meta port)
+
+USE_KDE4= kdeprefix
+NO_BUILD= yes
+NO_INSTALL= yes
+NO_MTREE= yes
+
+OPTIONS_DEFINE= FILESHARING KDNSSD KGET KOPETE KRDC KRFB STRIGI
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
-KOPETE_DESC= Multi-protocol instant messenger
-KRDC_DESC= RDP and VNC client for KDE
-KRFB_DESC= VNC server for KDE
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+FILESHARING_DESC= Network file sharing via Samba
+FILESHARING_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/sambausershareplugin.so:${PORTSDIR}/net/kdenetwork4-filesharing
+
+KDNSSD_DESC= Network monitor for DNS-SD services (Zeroconf)
+KDNSSD_RUN_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kded_dnssdwatcher.so:${PORTSDIR}/net/kdnssd
+
+KGET_DESC= Download manager
+KGET_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kget:${PORTSDIR}/net/kget
+
+KOPETE_DESC= Multi-protocol instant messenger
+KOPETE_RUN_DEPENDS= ${KDE4_PREFIX}/bin/kopete:${PORTSDIR}/net-im/kopete-kde4
-.if ${PORT_OPTIONS:MKOPETE}
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kopete:${PORTSDIR}/net-im/kopete-kde4
-.endif
+KRDC_DESC= RDP and VNC client
+KRDC_RUN_DEPENDS= ${KDE4_PREFIX}/bin/krdc:${PORTSDIR}/net/krdc
-.if ${PORT_OPTIONS:MKRDC}
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/krdc:${PORTSDIR}/net/krdc
-.endif
+KRFB_DESC= Desktop Sharing (VNC server)
+KRFB_RUN_DEPENDS= ${KDE4_PREFIX}/bin/krfb:${PORTSDIR}/net/krfb
-.if ${PORT_OPTIONS:MKRFB}
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/krfb:${PORTSDIR}/net/krfb
-.endif
+STRIGI_DESC= Strigi analyzers for network-related file formats
+STRIGI_RUN_DEPENDS= ${KDE4_PREFIX}/lib/strigi/strigita_torrent_analyzer.so:${PORTSDIR}/net/kdenetwork4-strigi-analyzers
.include <bsd.port.mk>
diff --git a/net/kdenetwork4/distinfo b/net/kdenetwork4/distinfo
deleted file mode 100644
index 8e2b1f4f365b..000000000000
--- a/net/kdenetwork4/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (KDE/4.10.5/kdenetwork-4.10.5.tar.xz) = d308c7f4f14e5ca91d69e661538e051335de389ca1eb9a74c1cd92ad40092ad3
-SIZE (KDE/4.10.5/kdenetwork-4.10.5.tar.xz) = 9030076
diff --git a/net/kdenetwork4/files/patch-CMakeLists.txt b/net/kdenetwork4/files/patch-CMakeLists.txt
deleted file mode 100644
index d621defb19b2..000000000000
--- a/net/kdenetwork4/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- CMakeLists.txt~ 2013-07-03 17:37:37.959108794 +0300
-+++ CMakeLists.txt 2013-07-03 17:37:44.152442094 +0300
-@@ -19,7 +19,6 @@
-
- macro_optional_add_subdirectory( kdenetwork-strigi-analyzers )
- macro_optional_add_subdirectory( kdenetwork-filesharing )
--macro_optional_add_subdirectory( kppp )
- macro_optional_add_subdirectory( kdnssd )
- macro_optional_add_subdirectory( krdc )
- macro_optional_add_subdirectory( krfb )
diff --git a/net/kdenetwork4/files/patch-kget__transfer-plugins__bittorrent__CMakeLists.txt b/net/kdenetwork4/files/patch-kget__transfer-plugins__bittorrent__CMakeLists.txt
deleted file mode 100644
index 70aa2ce3ec6a..000000000000
--- a/net/kdenetwork4/files/patch-kget__transfer-plugins__bittorrent__CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./kget/transfer-plugins/bittorrent/CMakeLists.txt.orig 2010-05-17 00:04:17.000000000 +0400
-+++ ./kget/transfer-plugins/bittorrent/CMakeLists.txt 2010-09-03 23:11:25.423061403 +0400
-@@ -1,6 +1,6 @@
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${KDE4_ENABLE_EXCEPTIONS}")
-
--include_directories(
-+include_directories(BEFORE
- ../../
- ${LIBKTORRENT_INCLUDE_DIR}
- )
diff --git a/net/kdenetwork4/pkg-descr b/net/kdenetwork4/pkg-descr
index 2c218fb7a253..a74871663977 100644
--- a/net/kdenetwork4/pkg-descr
+++ b/net/kdenetwork4/pkg-descr
@@ -1 +1 @@
-Network tools for KDE4.
+KDE Network Metapackage.
diff --git a/net/kdenetwork4/pkg-plist b/net/kdenetwork4/pkg-plist
deleted file mode 100644
index 52fa8b0cc68f..000000000000
--- a/net/kdenetwork4/pkg-plist
+++ /dev/null
@@ -1,99 +0,0 @@
-bin/kget
-lib/kde4/kcm_kget_bittorrentfactory.so
-lib/kde4/kcm_kget_checksumsearchfactory.so
-lib/kde4/kcm_kget_metalinkfactory.so
-lib/kde4/kcm_kget_mirrorsearchfactory.so
-lib/kde4/kcm_kget_mmsfactory.so
-lib/kde4/kcm_kget_multisegkiofactory.so
-lib/kde4/kded_dnssdwatcher.so
-lib/kde4/kget_bittorrentfactory.so
-lib/kde4/kget_browser_integration.so
-lib/kde4/kget_checksumsearchfactory.so
-lib/kde4/kget_kiofactory.so
-lib/kde4/kget_metalinkfactory.so
-lib/kde4/kget_mirrorsearchfactory.so
-lib/kde4/kget_mmsfactory.so
-lib/kde4/kget_multisegkiofactory.so
-lib/kde4/kio_zeroconf.so
-lib/kde4/krunner_kget.so
-lib/kde4/plasma_engine_kget.so
-lib/kde4/plasma_kget_barapplet.so
-lib/kde4/plasma_kget_piechart.so
-lib/kde4/sambausershareplugin.so
-lib/libkgetcore.so
-lib/libkgetcore.so.5
-lib/libkgetcore.so.5.0.1
-lib/strigi/strigita_torrent_analyzer.so
-share/applications/kde4/kget.desktop
-share/apps/dolphinpart/kpartplugins/kget_plug_in.desktop
-share/apps/dolphinpart/kpartplugins/kget_plug_in.rc
-share/apps/kconf_update/kget.upd
-share/apps/kconf_update/kget_limitdownloads.pl
-share/apps/kconf_update/kget_sensitive.pl
-share/apps/kget/kget.notifyrc
-share/apps/kget/kgetui.rc
-share/apps/kget/pics/kget_splash.png
-share/apps/kget/www/blank.gif
-share/apps/kget/www/favicon.ico
-share/apps/kget/www/header-background.png
-share/apps/kget/www/header-separator.png
-share/apps/kget/www/hi64-apps-kget.png
-share/apps/kget/www/iepngfix.htc
-share/apps/kget/www/index.htm
-share/apps/kget/www/mootools-core-yc.js
-share/apps/kget/www/mootools-more.js
-share/apps/kget/www/new-download-background.png
-share/apps/kget/www/preferences-system.png
-share/apps/kget/www/title-border-bottom-downloads.png
-share/apps/kget/www/title-border-bottom-settings.png
-share/apps/kget/www/view-refresh.png
-share/apps/khtml/kpartplugins/kget_plug_in.desktop
-share/apps/khtml/kpartplugins/kget_plug_in.rc
-share/apps/kwebkitpart/kpartplugins/kget_plug_in.desktop
-share/apps/kwebkitpart/kpartplugins/kget_plug_in.rc
-share/apps/remoteview/zeroconf.desktop
-share/config.kcfg/kget.kcfg
-share/config.kcfg/kget_checksumsearchfactory.kcfg
-share/config.kcfg/kget_mirrorsearchfactory.kcfg
-share/config.kcfg/kget_mmsfactory.kcfg
-share/config.kcfg/kget_multisegkiofactory.kcfg
-share/dbus-1/interfaces/org.kde.kdnssd.xml
-share/dbus-1/services/org.kde.kget.service
-share/icons/hicolor/128x128/apps/kget.png
-share/icons/hicolor/16x16/apps/kget.png
-share/icons/hicolor/22x22/apps/kget.png
-share/icons/hicolor/32x32/apps/kget.png
-share/icons/hicolor/48x48/apps/kget.png
-share/icons/hicolor/64x64/apps/kget.png
-share/icons/hicolor/scalable/apps/kget.svgz
-share/kde4/services/ServiceMenus/kget_download.desktop
-share/kde4/services/kded/dnssdwatcher.desktop
-share/kde4/services/kget_bittorrentfactory.desktop
-share/kde4/services/kget_bittorrentfactory_config.desktop
-share/kde4/services/kget_checksumsearchfactory.desktop
-share/kde4/services/kget_checksumsearchfactory_config.desktop
-share/kde4/services/kget_kiofactory.desktop
-share/kde4/services/kget_metalinkfactory.desktop
-share/kde4/services/kget_metalinkfactory_config.desktop
-share/kde4/services/kget_mirrorsearchfactory.desktop
-share/kde4/services/kget_mirrorsearchfactory_config.desktop
-share/kde4/services/kget_mmsfactory.desktop
-share/kde4/services/kget_mmsfactory_config.desktop
-share/kde4/services/kget_multisegkiofactory.desktop
-share/kde4/services/kget_multisegkiofactory_config.desktop
-share/kde4/services/kgetbarapplet-default.desktop
-share/kde4/services/kgetpiechartapplet-default.desktop
-share/kde4/services/plasma-engine-kget.desktop
-share/kde4/services/plasma-runner-kget.desktop
-share/kde4/services/sambausershareplugin.desktop
-share/kde4/services/zeroconf.protocol
-share/kde4/servicetypes/kget_plugin.desktop
-share/ontology/kde/kget_history.ontology
-share/ontology/kde/kget_history.trig
-@dirrmtry share/apps/kwebkitpart/kpartplugins
-@dirrmtry share/apps/kwebkitpart
-@dirrm share/apps/kget/www
-@dirrm share/apps/kget/pics
-@dirrm share/apps/kget
-@dirrmtry share/apps/dolphinpart/kpartplugins
-@dirrmtry share/apps/dolphinpart