aboutsummaryrefslogtreecommitdiff
path: root/net/kea/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-11-10 20:46:36 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-11-10 20:46:36 +0000
commitd6af702448c21ba8f6df23751f66bb22ed1ade2e (patch)
tree6d039c64c3c410bda2313b1fcf3b8d3a2be437d2 /net/kea/Makefile
parent5614c5d79a4bcf0b24cf207882d5445f842a959b (diff)
downloadports-d6af702448c21ba8f6df23751f66bb22ed1ade2e.tar.gz
ports-d6af702448c21ba8f6df23751f66bb22ed1ade2e.zip
net/kea: update 1.3.0 -> 1.4.0-P1
PR: 229088 Submitted by: Andrey Pevnev <apevnev@me.com> Reviewed by: Jeff Kletsky <jeff+freebsd@wagsky.com> Approved by: hrs (maintainer timeout) Relnotes: https://ftp.isc.org/isc/kea/1.4.0/Kea140ReleaseNotes.txt https://ftp.isc.org/isc/kea/1.4.0-P1/Kea140P1ReleaseNotes.txt https://www.isc.org/blogs/kea-1-4-adds-high-availability-mode/ https://kb.isc.org/docs/aa-01615
Notes
Notes: svn path=/head/; revision=484642
Diffstat (limited to 'net/kea/Makefile')
-rw-r--r--net/kea/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/net/kea/Makefile b/net/kea/Makefile
index e91c1844c4b0..a448d6477e29 100644
--- a/net/kea/Makefile
+++ b/net/kea/Makefile
@@ -1,10 +1,11 @@
# $FreeBSD$
PORTNAME= kea
-PORTVERSION= 1.3.0
-PORTREVISION= 4
+PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
+PORTREVISION= 0
CATEGORIES= net ipv6
-MASTER_SITES= ISC/kea/${PORTVERSION}
+MASTER_SITES= ISC/kea/${ISCVERSION}
+DISTNAME= ${PORTNAME}-${ISCVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Alternative DHCP implementation by ISC
@@ -17,7 +18,16 @@ LIB_DEPENDS= liblog4cplus.so:devel/log4cplus \
BROKEN_powerpc64= fails to configure: checking for log4cplus library... no
-USES= autoreconf compiler:c++11-lang libtool pathfix ssl
+# ISC releases things like 1.4.0-P1, which our versioning doesn't like
+ISCVERSION= 1.4.0-P1
+
+CPE_VENDOR= isc
+CPE_VERSION= ${ISCVERSION:C/-.*//}
+.if ${ISCVERSION:M*-*}
+CPE_UPDATE= ${ISCVERSION:C/.*-//:tl}
+.endif
+
+USES= autoreconf compiler:c++11-lang libtool pathfix ssl cpe
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes