aboutsummaryrefslogtreecommitdiff
path: root/net/keama/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2022-11-09 18:20:40 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2022-11-09 18:20:40 +0000
commitefe0b339c9c72b2f55cbbca2dcb781a8ccec5930 (patch)
treef721ef70d22b079a24fb4463d9221bbc6a297c4d /net/keama/Makefile
parentf664b99381e43b7c7ccb4a9695f222deef64a8e8 (diff)
downloadports-efe0b339c9c72b2f55cbbca2dcb781a8ccec5930.tar.gz
ports-efe0b339c9c72b2f55cbbca2dcb781a8ccec5930.zip
net/keama: Kea migration assistant
Diffstat (limited to 'net/keama/Makefile')
-rw-r--r--net/keama/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/net/keama/Makefile b/net/keama/Makefile
new file mode 100644
index 000000000000..78c5306279bd
--- /dev/null
+++ b/net/keama/Makefile
@@ -0,0 +1,43 @@
+PORTNAME= keama
+ISCVERSION= 4.4.3-P1
+PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
+CATEGORIES= net
+MASTER_SITES= ISC/${PORTNAME}/${PORTVERSION:S/P/-P/g} \
+ ZI
+DISTNAME= dhcp-${ISCVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Kea migration assistant
+WWW= https://gitlab.isc.org/isc-projects/dhcp/-/wikis/kea-migration-assistant
+
+LICENSE= MPL20
+
+USES= cpe gmake
+
+CPE_VENDOR= isc
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--localstatedir=/var
+CPPFLAGS+= -D_PATH_DHCPD_CONF='\"${PREFIX}/etc/dhcpd.conf\"'
+CFLAGS+= -fPIC
+BUILD_WRKSRC= ${WRKSRC}/keama
+MAN_COMPRESSED= no
+SCRIPTS_ENV+= PKG_PREFIX=${PREFIX}
+
+DOCSDIR= ${PREFIX}/share/doc/${PKGBASE}
+
+PLIST_FILES= sbin/keama man/man8/keama.8.gz \
+ %%PORTDOCS%%%%DOCSDIR%%/ChangeLog.md \
+ %%PORTDOCS%%%%DOCSDIR%%/README.md \
+
+do-install:
+ ${SETENV} DESTDIR=${STAGEDIR} ${MAKE} -C ${WRKSRC}/keama install
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}/${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/keama/*.md ${STAGEDIR}/${DOCSDIR}/
+
+.include <bsd.port.mk>