aboutsummaryrefslogtreecommitdiff
path: root/net/ldap2dns/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
commit1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66 (patch)
tree8b44219153a720f367633c8fe248933750735b7d /net/ldap2dns/Makefile
parent7cb0f3c9b4ec333deb7e94ba00c6dc2d3b9c6220 (diff)
downloadports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.tar.gz
ports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.zip
Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.
USES=localbase:ldflags can be used to set LDFLAGS. Normally LDFLAGS appears too early on the command line causing some ports to link with their own libraries in LOCALBASE (if installed) instead of WRKSRC. Also make use of _USES_POST so -L${LOCALBASE}/lib is added as late as possible after anything a port Makefile might set. Use _USES_POST instead of .include in libedit.mk and libarchive.mk so things like 'USES=libedit localbase:ldflags' work correctly. Fix some issues with LIBS in some ports. Switch ports that don't support LIBS to localbase:ldflags. PR: 212987 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=423014
Diffstat (limited to 'net/ldap2dns/Makefile')
-rw-r--r--net/ldap2dns/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/ldap2dns/Makefile b/net/ldap2dns/Makefile
index 26c8978ccd44..b9552ebb2716 100644
--- a/net/ldap2dns/Makefile
+++ b/net/ldap2dns/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS \
USE_GITHUB= yes
GH_ACCOUNT= bklang
-USES= gmake localbase perl5 shebangfix
+USES= gmake localbase:ldflags perl5 shebangfix
SHEBANG_FILES= scripts/*.pl
USE_PERL5= run
USE_OPENLDAP= yes