aboutsummaryrefslogtreecommitdiff
path: root/net/ldapscripts/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-10-13 14:57:21 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-10-13 14:57:21 +0000
commitd18b0a970c027db6fb2f5b271cbe271cec756880 (patch)
tree3260fa24c8b633595b1c1a698bf91cd6df0eca97 /net/ldapscripts/Makefile
parent8e1954ee4714778f2837088ecddea060b6445ef2 (diff)
downloadports-d18b0a970c027db6fb2f5b271cbe271cec756880.tar.gz
ports-d18b0a970c027db6fb2f5b271cbe271cec756880.zip
- Update to 1.7.1
PR: ports/117152 Submitted by: Ganael Laplanche <ganael.laplanche at martymac.com> (maintainer) Security: CVE-2007-5373
Notes
Notes: svn path=/head/; revision=201401
Diffstat (limited to 'net/ldapscripts/Makefile')
-rw-r--r--net/ldapscripts/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/net/ldapscripts/Makefile b/net/ldapscripts/Makefile
index 96dde154ca4b..238f69e63702 100644
--- a/net/ldapscripts/Makefile
+++ b/net/ldapscripts/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ldapscripts
-PORTVERSION= 1.7
+PORTVERSION= 1.7.1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://contribs.martymac.com/ldapscripts/
@@ -46,6 +46,7 @@ post-patch:
${REINPLACE_CMD} -E -e "s|^_RUNTIMEFILE=.*|_RUNTIMEFILE=\"${ETCDIR}/runtime\"|g" ${WRKSRC}/bin/*
${REINPLACE_CMD} -E -e "s|^_CONFIGFILE=.*|_CONFIGFILE=\"${ETCDIR}/ldapscripts.conf\"|g" ${WRKSRC}/etc/runtime
+ ${REINPLACE_CMD} -E -e "s|^BINDPWDFILE=.*|BINDPWDFILE=\"${ETCDIR}/ldapscripts.passwd\"|g" ${WRKSRC}/etc/ldapscripts.conf
${REINPLACE_CMD} -E -e "s|^LDAPSEARCHBIN=.*|LDAPSEARCHBIN=\"${PREFIX}/bin/ldapsearch\"|g" ${WRKSRC}/etc/ldapscripts.conf
${REINPLACE_CMD} -E -e "s|^LDAPADDBIN=.*|LDAPADDBIN=\"${PREFIX}/bin/ldapadd\"|g" ${WRKSRC}/etc/ldapscripts.conf
${REINPLACE_CMD} -E -e "s|^LDAPDELETEBIN=.*|LDAPDELETEBIN=\"${PREFIX}/bin/ldapdelete\"|g" ${WRKSRC}/etc/ldapscripts.conf
@@ -77,9 +78,15 @@ do-install:
${MKDIR} ${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/etc/ldapscripts.conf ${ETCDIR}/ldapscripts.conf.sample
+ ${CHMOD} 0440 ${ETCDIR}/ldapscripts.conf.sample
if [ ! -f ${ETCDIR}/ldapscripts.conf ]; then \
${CP} -p ${ETCDIR}/ldapscripts.conf.sample ${ETCDIR}/ldapscripts.conf; \
fi
+ ${INSTALL_DATA} ${WRKSRC}/etc/ldapscripts.passwd ${ETCDIR}/ldapscripts.passwd.sample
+ ${CHMOD} 0440 ${ETCDIR}/ldapscripts.passwd.sample
+ if [ ! -f ${ETCDIR}/ldapscripts.passwd ]; then \
+ ${CP} -p ${ETCDIR}/ldapscripts.passwd.sample ${ETCDIR}/ldapscripts.passwd; \
+ fi
${INSTALL_DATA} ${WRKSRC}/etc/runtime ${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/etc/ldapaddgroup.template.sample ${ETCDIR}
${INSTALL_DATA} ${WRKSRC}/etc/ldapadduser.template.sample ${ETCDIR}
@@ -97,4 +104,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/man/man1/* ${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/man5/* ${MAN5PREFIX}/man/man5
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>