aboutsummaryrefslogtreecommitdiff
path: root/net/libdaq
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-08-06 10:00:47 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-08-06 10:00:47 +0000
commit21af896a7d96993cffc2956419e951be104944f2 (patch)
treed653372ee80b5506efe4cdb3043a75a0cbfdeca2 /net/libdaq
parentb02e019cb91092499f085ac21bfce3e9718d635e (diff)
downloadports-21af896a7d96993cffc2956419e951be104944f2.tar.gz
ports-21af896a7d96993cffc2956419e951be104944f2.zip
Add compiler:c++11-lang to USES to fix build error on GCC-based archs:
configure: error: *** A compiler with support for C++11 language features is required. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=508243
Diffstat (limited to 'net/libdaq')
-rw-r--r--net/libdaq/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/libdaq/Makefile b/net/libdaq/Makefile
index 9373ef20a5e1..889a8f9a19bc 100644
--- a/net/libdaq/Makefile
+++ b/net/libdaq/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpcap.so:net/libpcap # avoid base libpcap
-USES= autoreconf libtool pkgconfig
+USES= autoreconf compiler:c++11-lang libtool pkgconfig
USE_GITHUB= yes
USE_LDCONFIG= yes
@@ -25,4 +25,5 @@ LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
CONFLICTS= daq-2*
+
.include <bsd.port.mk>