aboutsummaryrefslogtreecommitdiff
path: root/net/libdnet/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-16 22:12:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-16 22:12:24 +0000
commit0edf310d205b301b0fba8470dd91ea4f427ef501 (patch)
tree97a48b42fcf8e99af17a19e6893110ebab3fcd13 /net/libdnet/Makefile
parentc1d95aab80a9551d7e7451ed91c8342ef63d180c (diff)
downloadports-0edf310d205b301b0fba8470dd91ea4f427ef501.tar.gz
ports-0edf310d205b301b0fba8470dd91ea4f427ef501.zip
- Update to 1.10
- Add knob for python bindings, default off PR: ports/78774 Submitted by: Jonathan <onatan@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=131440
Diffstat (limited to 'net/libdnet/Makefile')
-rw-r--r--net/libdnet/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/net/libdnet/Makefile b/net/libdnet/Makefile
index 342ab485296f..43f5ac4c5306 100644
--- a/net/libdnet/Makefile
+++ b/net/libdnet/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libdnet
-PORTVERSION= 1.9
+PORTVERSION= 1.10
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +19,23 @@ USE_GMAKE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER=15
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+CONFIGURE_ARGS+= --with-python
+PLIST_FILES+= lib/${PYTHON_VERSION}/site-packages/dnet.so
+.else
+CONFIGURE_ARGS+= --without-python
+.endif
+
MAN3= dnet.3
MAN8= dnet.8
+pre-everything::
+.if !defined(WITH_PYTHON)
+ @${ECHO_MSG} "===>"
+ @${ECHO_MSG} "===> You can add python support using WITH_PYTHON,"
+ @${ECHO_MSG} "===>"
+ @sleep 2
+.endif
+
.include <bsd.port.mk>