aboutsummaryrefslogtreecommitdiff
path: root/net/libopennet/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-16 02:17:17 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-16 02:17:17 +0000
commit06d1784e5e55e602fd7479cb827b71143459887d (patch)
treeb3e388f7f60d70259c7fd3aa1448fa7e48d1d427 /net/libopennet/Makefile
parent9d449230820fe6d4f0f0472b55c6f2dba3eb6747 (diff)
downloadports-06d1784e5e55e602fd7479cb827b71143459887d.tar.gz
ports-06d1784e5e55e602fd7479cb827b71143459887d.zip
- Add LICENSE
- Strip library
Notes
Notes: svn path=/head/; revision=389820
Diffstat (limited to 'net/libopennet/Makefile')
-rw-r--r--net/libopennet/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/net/libopennet/Makefile b/net/libopennet/Makefile
index eef0afff3d6f..8c20ceb4db2c 100644
--- a/net/libopennet/Makefile
+++ b/net/libopennet/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libopennet
PORTVERSION= 0.9.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.rkeene.org/files/oss/libopennet/ \
http://www.cs.nctu.edu.tw/~gslin/files/
@@ -10,9 +11,16 @@ MASTER_SITES= http://www.rkeene.org/files/oss/libopennet/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for opening files over a network
+LICENSE= LGPL21 GPLv2 # net.c header mentions GPL
+LICENSE_COMB= multi
+LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE
+
GNU_CONFIGURE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
USES= gmake
USE_LDCONFIG= yes
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopennet.so
+
.include <bsd.port.mk>