aboutsummaryrefslogtreecommitdiff
path: root/net/libosip2
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-10-25 23:58:28 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-10-25 23:58:28 +0000
commit32b1e285ef5a0cc583d8055f3e9a37cb0d750fd0 (patch)
treead6ee0cf8dbbef977a8f42d6ceacdf44d40bae84 /net/libosip2
parentf839adbdee14036225c59316f24b12be386a9a8c (diff)
downloadports-32b1e285ef5a0cc583d8055f3e9a37cb0d750fd0.tar.gz
ports-32b1e285ef5a0cc583d8055f3e9a37cb0d750fd0.zip
Improve libtool handling of library names.
PR: 44117 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=68836
Diffstat (limited to 'net/libosip2')
-rw-r--r--net/libosip2/Makefile5
-rw-r--r--net/libosip2/files/patch-configure10
-rw-r--r--net/libosip2/pkg-plist11
3 files changed, 17 insertions, 9 deletions
diff --git a/net/libosip2/Makefile b/net/libosip2/Makefile
index 0bb49f816236..81ccf23720a5 100644
--- a/net/libosip2/Makefile
+++ b/net/libosip2/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libosip
PORTVERSION= 0.8.9
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= osip
@@ -15,9 +16,9 @@ MASTER_SITE_SUBDIR= osip
MAINTAINER= ports@FreeBSD.org
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION}
post-patch:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
diff --git a/net/libosip2/files/patch-configure b/net/libosip2/files/patch-configure
new file mode 100644
index 000000000000..d7ca4400c4ef
--- /dev/null
+++ b/net/libosip2/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Fri Sep 6 08:22:31 2002
++++ configure Sat Oct 12 16:00:32 2002
+@@ -5181,6 +5181,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/net/libosip2/pkg-plist b/net/libosip2/pkg-plist
index 7503b826385e..28a6f7aca012 100644
--- a/net/libosip2/pkg-plist
+++ b/net/libosip2/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
include/osip/const.h
include/osip/dialog.h
include/osip/fifo.h
@@ -13,14 +14,10 @@ include/osip/smsg.h
include/osip/smsgtypes.h
include/osip/thread.h
include/osip/urls.h
-@dirrm include/osip
-lib/libfsmtl-%%PORTVERSION%%.so
-lib/libfsmtl-%%PORTVERSION%%.so.0
lib/libfsmtl.a
-lib/libfsmtl.la
lib/libfsmtl.so
-lib/libosip-%%PORTVERSION%%.so
-lib/libosip-%%PORTVERSION%%.so.0
+lib/libfsmtl.so.0
lib/libosip.a
-lib/libosip.la
lib/libosip.so
+lib/libosip.so.0
+@dirrm include/osip