aboutsummaryrefslogtreecommitdiff
path: root/net/libproxy-gnome
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-27 05:28:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-02-27 05:28:08 +0000
commit8b210a18518382cb81637385569c8b36948b2241 (patch)
treed5b0190a0396ec4ee29a62fa12cbf33b13e69ff3 /net/libproxy-gnome
parent6b3986914a3155d162d7d2ddfcd936c38e3d1c7c (diff)
downloadports-8b210a18518382cb81637385569c8b36948b2241.tar.gz
ports-8b210a18518382cb81637385569c8b36948b2241.zip
Add libproxy-gnome, a plug-in which allows GNOME applications to make use
of libproxy.
Notes
Notes: svn path=/head/; revision=229132
Diffstat (limited to 'net/libproxy-gnome')
-rw-r--r--net/libproxy-gnome/Makefile30
-rw-r--r--net/libproxy-gnome/pkg-descr7
-rw-r--r--net/libproxy-gnome/pkg-plist1
3 files changed, 38 insertions, 0 deletions
diff --git a/net/libproxy-gnome/Makefile b/net/libproxy-gnome/Makefile
new file mode 100644
index 000000000000..38ebe8c816d0
--- /dev/null
+++ b/net/libproxy-gnome/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libproxy-gnome
+# Date created: 26 February 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= net devel
+PKGNAMESUFFIX= -gnome
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME plug-in for libproxy
+
+LIB_DEPENDS= proxy.0:${PORTSDIR}/net/libproxy
+
+MASTERDIR= ${.CURDIR}/../libproxy
+BUILD_WRKSRC= ${WRKSRC}/src/plugins
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+USE_XORG= xmu x11
+USE_GNOME= gconf2
+CONFIGURE_ARGS=--with-gnome --without-kde --without-webkit \
+ --without-mozjs --without-networkmanager --without-python \
+ --without-envvar --without-file
+
+LIBPROXY_SLAVE= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/libproxy-gnome/pkg-descr b/net/libproxy-gnome/pkg-descr
new file mode 100644
index 000000000000..60ce67f8faae
--- /dev/null
+++ b/net/libproxy-gnome/pkg-descr
@@ -0,0 +1,7 @@
+Libproxy exists to answer the question: Given a network resource, how do I
+reach it? It handles all the details, enabling you to get back to
+programming.
+
+This plug-in allows the GNOME Desktop to make use of libproxy.
+
+WWW: http://code.google.com/p/libproxy/
diff --git a/net/libproxy-gnome/pkg-plist b/net/libproxy-gnome/pkg-plist
new file mode 100644
index 000000000000..0ee9c67e3789
--- /dev/null
+++ b/net/libproxy-gnome/pkg-plist
@@ -0,0 +1 @@
+lib/libproxy/%%VERSION%%/plugins/gnome.so