aboutsummaryrefslogtreecommitdiff
path: root/net/libzmq2/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-12-04 14:08:03 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-12-04 14:08:03 +0000
commitc71b83c89e150096e612d4127bf56eb961f7cb18 (patch)
tree754b3663485f9b13ff4b8f3685115ac80f066624 /net/libzmq2/Makefile
parent6c803a1da7a57d3ad2040622bacc669dc80cbbae (diff)
downloadports-c71b83c89e150096e612d4127bf56eb961f7cb18.tar.gz
ports-c71b83c89e150096e612d4127bf56eb961f7cb18.zip
devel/zmq: Move to net/libzmq2 & update to align with other ZeroMQ ports
All other core ZeroMQ library ports have been moved to the net/ category along with the czmq client library. This change completes the set, enabling greater flexibility and choice for maintainers of ZeroMQ-based software in the ports tree. - Move devel/zmq to net/libzmq2 - Update devel/ and net/ category Makefiles - Add MOVED entry - Update LIB_DEPENDS in dependent ports net/libzmq2: - Switch primary category to net - Enable STAGE support - Add DEBUG option - Update COMMENT to match libzmq[34] - Update pkg-descr to match libzmq[34] - Update CONFLICTS - Add LICENSE - Sort USE_* section - Remove MAN macros and move entries to pkg-plist - Add regression-test target for QA Reviewed by: makc Approved by: Gea-Suan Lin <gslin@gslin.org> (maintainer, via email)
Notes
Notes: svn path=/head/; revision=335619
Diffstat (limited to 'net/libzmq2/Makefile')
-rw-r--r--net/libzmq2/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/libzmq2/Makefile b/net/libzmq2/Makefile
new file mode 100644
index 000000000000..9a9061b866d0
--- /dev/null
+++ b/net/libzmq2/Makefile
@@ -0,0 +1,37 @@
+# Created by: Gea-Suan Lin <gslin@gslin.org>
+# $FreeBSD$
+
+PORTNAME= zmq
+PORTVERSION= 2.2.0
+PORTREVISION= 1
+CATEGORIES= net
+MASTER_SITES= http://download.zeromq.org/
+DISTNAME= zeromq-${DISTVERSION}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= ZeroMQ core library (Version 2)
+
+LICENSE= LGPL3
+
+USES= pathfix
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+CONFLICTS= libzmq[^2]-[0-9]*
+
+OPTIONS_DEFINE= DEBUG
+DEBUG_CONFIGURE_ON= --enable-debug
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG}
+WITH_DEBUG= yes
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e '9s|$$| -pthread|' ${WRKSRC}/src/libzmq.pc.in
+
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} check
+
+.include <bsd.port.mk>