aboutsummaryrefslogtreecommitdiff
path: root/net/licq-devel
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-08-09 01:25:57 +0000
committerSteve Price <steve@FreeBSD.org>1998-08-09 01:25:57 +0000
commit5af3603f10bb010324be05ddf722ab771efa3201 (patch)
tree32382286b5fdd9e83cbbf7123f5aafbce6d4b73f /net/licq-devel
parentdbc64fac16eecbb8b327a91baf34446d4a8f7c5b (diff)
downloadports-5af3603f10bb010324be05ddf722ab771efa3201.tar.gz
ports-5af3603f10bb010324be05ddf722ab771efa3201.zip
Update to version 0.34
PR: 7502 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=12369
Diffstat (limited to 'net/licq-devel')
-rw-r--r--net/licq-devel/Makefile22
-rw-r--r--net/licq-devel/distinfo2
-rw-r--r--net/licq-devel/files/patch-aa103
-rw-r--r--net/licq-devel/files/patch-ab4
-rw-r--r--net/licq-devel/files/patch-ac17
-rw-r--r--net/licq-devel/files/patch-ad13
-rw-r--r--net/licq-devel/files/patch-ae35
-rw-r--r--net/licq-devel/pkg-plist40
8 files changed, 110 insertions, 126 deletions
diff --git a/net/licq-devel/Makefile b/net/licq-devel/Makefile
index 835d7f0c014c..69b129cf5d08 100644
--- a/net/licq-devel/Makefile
+++ b/net/licq-devel/Makefile
@@ -1,15 +1,14 @@
# New ports collection makefile for: licq
-# Version required: 0.32-a
+# Version required: 0.34
# Date created: 2 July 1998
# Whom: Brian Feldman
#
# $Id: Makefile,v 1.1.1.1 1998/07/09 16:01:50 eivind Exp $
#
-DISTNAME= licq-0.32-a
+DISTNAME= licq-0.34
CATEGORIES= net
MASTER_SITES= http://pages.infinit.net/fairoff/licq/
-EXTRACT_SUFX= .tgz
MAINTAINER= brianfeldman@hotmail.com
@@ -17,18 +16,9 @@ LIB_DEPENDS= qt\\.1\\.33:${PORTSDIR}/x11-toolkits/qt133
WRKSRC= ${WRKDIR}/${DISTNAME}
-do-install:
- ${RM} -rf ${PREFIX}/share/licq
- (cd ${WRKSRC}; make install)
- ${INSTALL_PROGRAM} ${PREFIX}/share/licq/licq \
- ${PREFIX}/bin/licq-binary
- ${RM} ${PREFIX}/share/licq/licq
- ${SED} 's|___INSERT_PREFIX_HERE___|PREFIX=${PREFIX}|' \
- < ${FILESDIR}/licq-wrapper \
- > ${PREFIX}/bin/licq
- chmod 555 ${PREFIX}/share/licq ${PREFIX}/bin/licq
-.for file in javaToLicq micqToLicq
- chmod 555 ${PREFIX}/share/licq/${file}
-.endfor
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/X11/qt --with-qt-libs=${X11BASE}/lib
.include <bsd.port.mk>
diff --git a/net/licq-devel/distinfo b/net/licq-devel/distinfo
index fd52e74bc8bb..65e9b8b12aad 100644
--- a/net/licq-devel/distinfo
+++ b/net/licq-devel/distinfo
@@ -1 +1 @@
-MD5 (licq-0.32-a.tgz) = 7ed0aed768cbb1a6d1996069918b708d
+MD5 (licq-0.34.tar.gz) = f4f3e39b116dc2a2a20c590136a7a362
diff --git a/net/licq-devel/files/patch-aa b/net/licq-devel/files/patch-aa
index 4bade35ed768..7a310c4a078d 100644
--- a/net/licq-devel/files/patch-aa
+++ b/net/licq-devel/files/patch-aa
@@ -1,87 +1,16 @@
-diff -ur Makefile Makefile
---- Makefile Sat Jul 4 18:46:51 1998
-+++ Makefile Sun Jul 5 10:33:57 1998
-@@ -1,7 +1,7 @@
- # stuff to check
-
- # base directory to install licq and the data sub directories to
--BASE_DIR=/usr/local/licq
-+BASE_DIR=/usr/local/share/licq
-
- all:
- (cd src; make; mv licq ..)
-@@ -10,10 +10,9 @@
- (cd src; make clean)
-
- install:
-- mkdir $(BASE_DIR)
-+ mkdir -p $(BASE_DIR)
- cp -R ./conf $(BASE_DIR)/conf
- cp -R ./data $(BASE_DIR)/data
- cp -R ./history $(BASE_DIR)/history
- cp ./licq ./licq.inst ./micqToLicq ./javaToLicq ./README $(BASE_DIR)
-- echo Now have each user who wants to use Licq run $(BASE_DIR)/licq.inst.
--
-+ @echo Now have each user who wants to use Licq run $(BASE_DIR)/licq.inst.
-diff -ur licq.inst licq.inst
---- licq.inst Sat Jul 4 18:42:37 1998
-+++ licq.inst Sun Jul 5 10:35:21 1998
-@@ -4,12 +4,12 @@
- # BASE_DIR = base directory where licq was installed, typically /usr/local/licq
- # INST_DIR = dir to install to, typically ~/licq
-
--BASE_DIR=/usr/local/licq
--INST_DIR=~/licq
-+BASE_DIR=/usr/local/share/licq
-+INST_DIR=~/.licq
-
- echo Installing Licq from $BASE_DIR to $INST_DIR.
- echo Making $INST_DIR...
--mkdir $INST_DIR
-+mkdir -p $INST_DIR
- echo Copying data to $INST_DIR...
- cp -R $BASE_DIR/data $INST_DIR/data
- cp -R $BASE_DIR/conf $INST_DIR/conf
-diff -ur src/Makefile src/Makefile
---- src/Makefile Sat Jul 4 20:51:29 1998
-+++ src/Makefile Sun Jul 5 10:23:36 1998
-@@ -1,6 +1,6 @@
- # ----- stuff to check -----
-
--QTDIR=-I/usr/lib/qt/include
-+QTDIR=-I/usr/X11R6/include/X11/qt
- GCC=g++
- MOC=moc
-
-diff -ur src/icq-defines.h src/icq-defines.h
---- src/icq-defines.h Sat Jul 4 12:27:15 1998
-+++ src/icq-defines.h Sun Jul 5 10:29:36 1998
-@@ -3,7 +3,7 @@
- #define ICQDEFINES_H
-
- // directory constants
--const char DEFAULT_BASE_DIR[] = "/usr/local/licq";
-+const char DEFAULT_BASE_DIR[] = "/usr/local/share/licq";
- const char CONF_DIR[] = "conf/";
- const char DATA_DIR[] = "data/";
- const char HISTORY_DIR[] = "history/";
-diff -ur src/socket.h src/socket.h
---- src/socket.h Tue Jun 9 21:35:43 1998
-+++ src/socket.h Sun Jul 5 10:26:14 1998
-@@ -1,6 +1,8 @@
- #ifndef socket_h
- #define socket_h
-
-+#include <sys/types.h>
-+#include <netinet/in.h>
- #include <arpa/inet.h>
- #include <qsocknot.h>
-
-diff -ur src/user.cpp src/user.cpp
---- src/user.cpp Sat Jul 4 20:17:53 1998
-+++ src/user.cpp Sun Jul 5 10:25:12 1998
-@@ -1,3 +1,4 @@
-+#include <sys/types.h>
- #include <netinet/in.h>
-
- #include "user.h"
+--- src/Makefile.in Tue Jul 14 16:18:02 1998
++++ src/Makefile.in Wed Aug 5 18:05:00 1998
+@@ -15,11 +15,11 @@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+
+ CXX = @CXX@
+-CXXFLAGS= @CXXFLAGS@
++CXXFLAGS= @CXXFLAGS@ -I.
+ CPPFLAGS= -DPACKAGE=\"@PACKAGE@\" -DVERSION=\"@VERSION@\" \
+ @QT_INCLUDES@ @X_INCLUDES@
+ LDFLAGS = @QT_LDFLAGS@ @X_LDFLAGS@
+-LDLIBS = -lqt
++LDLIBS = -lqt -lX11
+ MOC = @MOC@
+
+ OBJECTS = file.o message.o packet.o socket.o icqfunctions.o user.o \
diff --git a/net/licq-devel/files/patch-ab b/net/licq-devel/files/patch-ab
new file mode 100644
index 000000000000..5596382280d7
--- /dev/null
+++ b/net/licq-devel/files/patch-ab
@@ -0,0 +1,4 @@
+--- /dev/null Wed Aug 5 18:00:59 1998
++++ src/qmetaobject.h Wed Aug 5 18:03:45 1998
+@@ -0,0 +1 @@
++#include <qmetaobj.h>
diff --git a/net/licq-devel/files/patch-ac b/net/licq-devel/files/patch-ac
new file mode 100644
index 000000000000..a9b84b2ec4eb
--- /dev/null
+++ b/net/licq-devel/files/patch-ac
@@ -0,0 +1,17 @@
+--- src/icq.cpp Mon Jul 13 20:53:45 1998
++++ src/icq.cpp Wed Aug 5 18:02:39 1998
+@@ -338,7 +338,13 @@
+ case ICQ_CMD_PING: if (!gotAck) emit doneOwnerFcn(false, cmd); break;
+ case ICQ_CMD_ADDUSER: if (!gotAck) emit doneOwnerFcn(false, cmd); break;
+ case ICQ_CMD_AUTHORIZE: emit doneOwnerFcn(false, cmd); break;
+- case ICQ_CMD_LOGON: if (!gotAck) emit doneOwnerFcn(false, cmd); break;
++ case ICQ_CMD_LOGON:
++ if (!gotAck)
++ {
++ emit doneOwnerFcn(false, cmd);
++ logoff(false);
++ }
++ break;
+ case ICQ_CMD_USERLIST: if (!gotAck) emit doneOwnerFcn(false, cmd); break;
+ case ICQ_CMD_REQ_SYSMESG: if (!gotAck) emit doneOwnerFcn(false, cmd); break;
+ case ICQ_CMD_END_SM_ACK: if (!gotAck) emit doneOwnerFcn(false, cmd); break;
diff --git a/net/licq-devel/files/patch-ad b/net/licq-devel/files/patch-ad
new file mode 100644
index 000000000000..57d036b7e38e
--- /dev/null
+++ b/net/licq-devel/files/patch-ad
@@ -0,0 +1,13 @@
+--- src/socket.cpp Mon Jul 13 20:53:45 1998
++++ src/socket.cpp Wed Aug 5 18:02:18 1998
+@@ -69,8 +69,8 @@
+ // find local connection
+ hostent *localHost;
+ char hn[128];
+- gethostname(hn, 128);
+- localHost = gethostbyname(hn);
++ //gethostname(hn, 128);
++ localHost = gethostbyname("127.0.0.1");
+ localIPVal = *((unsigned long *)localHost->h_addr);
+
+ // set up remote connection
diff --git a/net/licq-devel/files/patch-ae b/net/licq-devel/files/patch-ae
new file mode 100644
index 000000000000..520256117bbc
--- /dev/null
+++ b/net/licq-devel/files/patch-ae
@@ -0,0 +1,35 @@
+--- src/mledit.cpp.orig Mon Jul 13 20:53:46 1998
++++ src/mledit.cpp Wed Aug 5 18:12:05 1998
+@@ -6,18 +6,25 @@
+ {
+ // add word wrap here
+ char *newText = new char[strlen(s) + 1];
+- int j = 0;
+- for (int i = 0; i < strlen(s); i++)
++ int j, m, n;
++ j = 0;
++ for (unsigned long i = 0; i < strlen(s); i++)
+ {
+ //if (s[i] == '\t') j += 3; // add whatever the length of a tab is (broken)
+ if (j > fill_column_value)
+ {
+ // backup until we get to a space or a newline
+- while (s[i] != ' ' && s[i] != '\n') { i--; j--; }
+- newText[j] = '\0';
+- QMultiLineEdit::append(newText);
+- j = 0;
+- i++; // get past the space or newline
++ m = i;
++ n = j;
++ while (m >= 0 && s[m] != ' ' && s[m] != '\n') { m--; n--; }
++ if (s[m] == ' ') // space found
++ {
++ i = m;
++ newText[n] = '\0';
++ QMultiLineEdit::append(newText);
++ j = 0;
++ i++; // get past the space or newline
++ }
+ }
+ if (s[i] == '\n')
+ {
diff --git a/net/licq-devel/pkg-plist b/net/licq-devel/pkg-plist
index 9bcc9c7d63dc..afb05be70375 100644
--- a/net/licq-devel/pkg-plist
+++ b/net/licq-devel/pkg-plist
@@ -1,23 +1,19 @@
bin/licq
-bin/licq-binary
-share/licq/conf/2127503.uin
-share/licq/conf/licq.conf
-share/licq/conf/sample.uin
-share/licq/conf/users.conf
-share/licq/data/0001.ppm
-share/licq/data/FFFF.ppm
-share/licq/data/0005.ppm
-share/licq/data/0000.ppm
-share/licq/data/0011.ppm
-share/licq/data/message.ppm
-share/licq/data/bg.ppm
-share/licq/history/8562000.history
-share/licq/history/2127503.history
-share/licq/README
-share/licq/javaToLicq
-share/licq/micqToLicq
-share/licq/licq.inst
-@dirrm share/licq/conf
-@dirrm share/licq/data
-@dirrm share/licq/history
-@dirrm share/licq
+bin/licq.inst
+bin/licq.javaconvert
+bin/licq.micqconvert
+share/Licq/data/online.ppm
+share/Licq/data/away.ppm
+share/Licq/data/na.ppm
+share/Licq/data/occupied.ppm
+share/Licq/data/offline.ppm
+share/Licq/data/bg.ppm
+share/Licq/data/message.ppm
+share/Licq/data/message.wav
+share/Licq/conf/2127503.uin
+share/Licq/conf/sample.uin
+share/Licq/conf/users.conf
+share/Licq/conf/licq.conf
+@dirrm share/Licq/data
+@dirrm share/Licq/conf
+@dirrm share/Licq